aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2013-12-07 22:11:17 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2013-12-07 22:11:17 +0100
commit1ac043b9402b96d6dd58d15a5b17a6039c97ac45 (patch)
tree90c7c743029a534127fbc6eb442e83da061faacc /debian/rules
parent1061630f1cc0e65914353bfc18f9461338ef318c (diff)
downloadnx-libs-1ac043b9402b96d6dd58d15a5b17a6039c97ac45.tar.gz
nx-libs-1ac043b9402b96d6dd58d15a5b17a6039c97ac45.tar.bz2
nx-libs-1ac043b9402b96d6dd58d15a5b17a6039c97ac45.zip
debian/rules: Remove bundled libraries from source tree before building the package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d8315b4a8..c6bc4b15b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,6 +27,7 @@ override_dh_auto_install:
PREFIX=/usr dh_auto_install -Smakefile
override_dh_auto_build:
+
# create copies of upstream changelogs so that names apply to Debian policy...
cp -a nx-X11/CHANGELOG nx-X11/changelog
cp -a nxcomp/CHANGELOG nxcomp/changelog
@@ -42,6 +43,12 @@ override_dh_auto_build:
ln -s ../debian/keystrokes.cfg etc/keystrokes.cfg
ln -s debian/rgb
ln -s debian/VERSION.x2goagent
+
+ # remove bundled libraries (keep this in sync with roll-tarball.sh)
+ rm -Rf nx-X11/extras/{drm,expat,fontconfig,freetype2,fonts,ogl-sample,regex,rman,ttf2pt1,x86emu,zlib}
+ rm -Rf nx-X11/lib/{expat,fontconfig,fontenc,font/FreeType,font/include/fontenc.h,freetype2,regex,zlib}
+ rm -Rf nx-X11/lib/{FS,ICE,SM,Xaw,Xft,Xt,Xmu,Xmuu}
+
LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh_auto_build --with quilt --parallel
override_dh_strip: