aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-28 14:58:17 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-28 16:35:07 +0100
commit2a4015865143f3f306e4d98859bdc95ba3954ea8 (patch)
tree4c02b2559ed5a48f07e200da57feaa9d159ad04e /debian/rules
parent8b432c7a5bbf99cc426f492d25fda988d162280c (diff)
downloadnx-libs-2a4015865143f3f306e4d98859bdc95ba3954ea8.tar.gz
nx-libs-2a4015865143f3f306e4d98859bdc95ba3954ea8.tar.bz2
nx-libs-2a4015865143f3f306e4d98859bdc95ba3954ea8.zip
Support hardened builds for nxcomp* libraries.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index f1ec96358..acef66c76 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,11 @@
#!/usr/bin/make -f
NULL =
-CFLAGS = -Wall -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
+export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+export CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
export LIBDIR = "/usr/lib/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
export INCLUDEDIR = "/usr/include/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"