aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-10-02 11:53:47 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-10-02 11:54:11 +0200
commit5a82f59941e6b6a35cbd02e3e42b2b0c32d1a0c9 (patch)
tree432ee6b712d82aad43651406c1cdb30ca395a4c1 /debian/rules
parent61d047d630bf1dceb61e25f63360969a5416e596 (diff)
downloadnx-libs-5a82f59941e6b6a35cbd02e3e42b2b0c32d1a0c9.tar.gz
nx-libs-5a82f59941e6b6a35cbd02e3e42b2b0c32d1a0c9.tar.bz2
nx-libs-5a82f59941e6b6a35cbd02e3e42b2b0c32d1a0c9.zip
debian/libnx-x11.postinst: Don't use dpkg-architecture (bin:package dpkg-dev) in postinst script. Instead prep a libnx-x11.postinst script at build time. (Fixes: #621).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 042061cf5..6e45185e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,7 @@ override_dh_clean:
rm -f nx-X11/programs/Xserver/hw/nxagent/changelog
rm -f nx-X11/programs/nxauth/changelog
rm -Rf replace.sh Makefile bin rgb VERSION.x2goagent etc/keystrokes.cfg
+ rm -f debian/libnx-x11.postinst
dh_clean
override_dh_auto_install:
@@ -45,6 +46,9 @@ override_dh_auto_build:
ln -sf VERSION.x2goagent debian/VERSION
ln -sf nxcomp/VERSION debian/VERSION
+ # let's prep the libnx-x11.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
+ sed debian/libnx-x11.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/libnx-x11.postinst
+
# remove bundled libraries (keep this in sync with roll-tarball.sh)
rm -Rf nx-X11/extras/{drm,expat,fontconfig,freetype2,fonts,ogl-sample,regex,rman,ttf2pt1,x86emu,zlib}
rm -Rf nx-X11/lib/{expat,fontconfig,fontenc,font/FreeType,font/include/fontenc.h,freetype2,regex,zlib}