aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-28 21:28:04 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-28 21:28:04 +0100
commit912d62ba50086aa47f2365c19ffe6ae9b3cb45c6 (patch)
tree1eaccbf9d87fde38442a7cc06387894fc55dc713 /debian/rules
parentf72fb34eb9941e935faf4c3f31324262a3f9b1a8 (diff)
downloadnx-libs-912d62ba50086aa47f2365c19ffe6ae9b3cb45c6.tar.gz
nx-libs-912d62ba50086aa47f2365c19ffe6ae9b3cb45c6.tar.bz2
nx-libs-912d62ba50086aa47f2365c19ffe6ae9b3cb45c6.zip
Install upstream ChangeLogs into bin:packages.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a4f9257ff..d21539472 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,6 +38,15 @@ override_dh_clean:
if [ -f nxcomp/.VERSION.NoMachine ]; then mv nxcomp/.VERSION.NoMachine nxcomp/VERSION; fi
dh_clean
+override_dh_installchangelog:
+
+ ### the doc/changelog file is the actual NX (redistributed) ChangeLog
+ #dh_installchangelog doc/changelog
+
+ ### the nx-X11/CHANGELOG is an old upstream ChangeLog by NoMachine that prevents us from
+ ### being shouted at by lintian (while testing the package build scripts)
+ dh_installchangelog nx-X11/CHANGELOG
+
override_dh_install:
# handle builds for Debian squeeze (non multi-arch)
@@ -108,6 +117,8 @@ override_dh_auto_build:
ln -s ../debian/rgb etc/rgb
ln -s ../debian/nxagent.keyboard etc/nxagent.keyboard
ln -s ../debian/x2goagent.keyboard etc/x2goagent.keyboard
+ mkdir -p doc/
+ ln -s ../debian/changelog doc/changelog
ln -sf debian/VERSION VERSION.x2goagent
ln -sf ../debian/VERSION nxcomp/VERSION