aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-28 08:15:52 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-28 08:35:42 +0200
commitd35a3622dd57f18cfa94051302a694cbc506d982 (patch)
tree341b28989d39f950d27e10f80b0a123e4b7d92a4 /debian/rules
parent3027f50195dfd3ca8a9cc482a949a5c04eec6bb6 (diff)
downloadnx-libs-d35a3622dd57f18cfa94051302a694cbc506d982.tar.gz
nx-libs-d35a3622dd57f18cfa94051302a694cbc506d982.tar.bz2
nx-libs-d35a3622dd57f18cfa94051302a694cbc506d982.zip
Xinerama symlinking: Attach Xinerama symlinking to nxagent bin:package (and not libnx-xinerama1).3.5.0.x
Backported from Arctica GH 3.6.x branch.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 6a82c674d..2cd77b383 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,7 +34,7 @@ override_dh_clean:
if [ ! -f replace.sh ] && [ ! -h replace.sh ]; then ln -s debian/Makefile.replace.sh replace.sh; fi
. ./replace.sh; set -x; ls debian/*.install.in | while read file; do rm -f $$(string_rep $$file .install.in .install); done
rm -fR replace.sh Makefile bin etc/rgb VERSION.x2goagent etc/keystrokes.cfg etc/nxagent.keyboard etc/x2goagent.keyboard
- rm -f debian/libnx-xinerama1.postinst
+ rm -f debian/nxagent.postinst
rm -fR .preserve/
if [ -f nxcomp/.VERSION.NoMachine ]; then mv nxcomp/.VERSION.NoMachine nxcomp/VERSION; fi
dh_clean
@@ -119,8 +119,8 @@ override_dh_auto_build:
ln -sf debian/VERSION VERSION.x2goagent
ln -sf ../debian/VERSION nxcomp/VERSION
- # let's prep the libnx-xinerama1.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
- sed debian/libnx-xinerama1.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/libnx-xinerama1.postinst
+ # let's prep the nxagent.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
+ sed debian/nxagent.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/nxagent.postinst
# make a copy of code to be preserved for build
mkdir -p .preserve