aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2016-06-30 10:27:31 +0200
committerMihai Moldovan <ionic@ionic.de>2016-06-30 10:27:31 +0200
commit112f0f8169427142da0ad7eeb5f55f81b7e1964f (patch)
tree7560e5f7138604b95ccb8229aaeb8c6fa12aa56b /debian/rules
parent9b0868985e23acd4558ff5d82382cc8d672ff07b (diff)
downloadnx-libs-112f0f8169427142da0ad7eeb5f55f81b7e1964f.tar.gz
nx-libs-112f0f8169427142da0ad7eeb5f55f81b7e1964f.tar.bz2
nx-libs-112f0f8169427142da0ad7eeb5f55f81b7e1964f.zip
debian/rules: symlink and remove new debian/x2goagent.options file into/from build environment.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2cd77b383..10a079872 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,7 +33,7 @@ override_dh_clean:
rm -f nx-X11/programs/nxauth/changelog
if [ ! -f replace.sh ] && [ ! -h replace.sh ]; then ln -s debian/Makefile.replace.sh replace.sh; fi
. ./replace.sh; set -x; ls debian/*.install.in | while read file; do rm -f $$(string_rep $$file .install.in .install); done
- rm -fR replace.sh Makefile bin etc/rgb VERSION.x2goagent etc/keystrokes.cfg etc/nxagent.keyboard etc/x2goagent.keyboard
+ rm -fR replace.sh Makefile bin etc/rgb VERSION.x2goagent etc/keystrokes.cfg etc/nxagent.keyboard etc/x2goagent.keyboard etc/x2goagent.options
rm -f debian/nxagent.postinst
rm -fR .preserve/
if [ -f nxcomp/.VERSION.NoMachine ]; then mv nxcomp/.VERSION.NoMachine nxcomp/VERSION; fi
@@ -114,6 +114,7 @@ override_dh_auto_build:
ln -s ../debian/rgb etc/rgb
ln -s ../debian/nxagent.keyboard etc/nxagent.keyboard
ln -s ../debian/x2goagent.keyboard etc/x2goagent.keyboard
+ ln -s ../debian/x2goagent.options etc/x2goagent.options
mkdir -p doc/
ln -s ../debian/changelog doc/changelog
ln -sf debian/VERSION VERSION.x2goagent