aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-07-01 14:02:52 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-07-01 14:02:52 +0200
commita3a295288189d1312f5abef0e7b4cc57b948e7d3 (patch)
treed3f008069f724c2e9d3b152a62b6505a8c2da6f7 /debian/rules
parent8307d4f330cde01a1f048598be184aa4bfa54501 (diff)
parent12ca29bf5418f0a7c4d7de57c5cd34c9151adac3 (diff)
downloadnx-libs-a3a295288189d1312f5abef0e7b4cc57b948e7d3.tar.gz
nx-libs-a3a295288189d1312f5abef0e7b4cc57b948e7d3.tar.bz2
nx-libs-a3a295288189d1312f5abef0e7b4cc57b948e7d3.zip
Merge branch 'sunweaver-pr/debian-packaging-updates' into 3.6.x
Attributes GH PR: https://github.com/ArcticaProject/nx-libs/pull/151 Self-reviewed: Mike Gabriel <mike.gabriel@das-netzwerkteam.de> -- Fri, 01 Jul 2016 14:03:44 +0200
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 3 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index 275956c9a..e41f97c81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,10 +2,9 @@
NULL =
-export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
-export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
-export CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
-export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
export LIBDIR = "/usr/lib/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
export INCLUDEDIR = "/usr/include/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
@@ -19,23 +18,10 @@ override_dh_auto_clean:
override_dh_clean:
rm -f nx*/configure
- . ./replace.sh; set -x; ls debian/*.install.in | while read file; do rm -f $$(string_rep $$file .install.in .install); done
- rm -fR .preserve/
dh_clean
override_dh_install:
- # handle builds for Debian squeeze (non multi-arch)
- . ./replace.sh; set -x; if [ -z "$(DEB_BUILD_MULTIARCH)" ]; then \
- find debian/*.install.in | while read file; do \
- cat $$file | sed -e 's#/\*/#/#g' > $$(string_rep $$file .install.in .install); \
- done; \
- else \
- find debian/*.install.in | while read file; do \
- cat $$file > $$(string_rep $$file .install.in .install); \
- done; \
- fi
-
# remove static libs
rm debian/tmp/usr/lib/$(DEB_BUILD_MULTIARCH)/libXcomp.a
rm debian/tmp/usr/lib/$(DEB_BUILD_MULTIARCH)/libXcompshad.a