aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon Matter <simon.matter@invoca.ch>2017-10-10 10:53:31 +0200
committerMihai Moldovan <ionic@ionic.de>2017-10-10 10:55:07 +0200
commite73464e4f1dcef8025226c7df47cc8b579c16f28 (patch)
treeefe824ead8a93448ea397106d6f06bffd4d0cfef /debian
parent1077270f8ac6ffdfc0b5dd7693cfe0aad7169ad9 (diff)
downloadnx-libs-e73464e4f1dcef8025226c7df47cc8b579c16f28.tar.gz
nx-libs-e73464e4f1dcef8025226c7df47cc8b579c16f28.tar.bz2
nx-libs-e73464e4f1dcef8025226c7df47cc8b579c16f28.zip
nxcomp: Reduce control->TokenSize slightly again in order to fix fragmentation of packages when on VPN (or otherwise encapsulated) connections.
Backported from Arctica GH 3.6.x branch. v2: backport to nx-libs 3.5.0.x (Mihai Moldovan) Adds: - debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch34
2 files changed, 43 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bd0f8ffbd..820dacd6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -77,6 +77,15 @@ nx-libs (2:3.5.0.33-0x2go1) UNRELEASED; urgency=low
Adds:
- debian/patches/1400_nx-X11_Render.c-Improve-situation-fo.full+lite.patch
+ [ Simon Matter ]
+ * nxcomp: Reduce control->TokenSize slightly again in order to fix
+ fragmentation of packages when on VPN (or otherwise encapsulated)
+ connections.
+ Backported from Arctica GH 3.6.x branch.
+ v2: backport to nx-libs 3.5.0.x (Mihai Moldovan)
+ Adds:
+ - debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch
+
-- X2Go Release Manager <git-admin@x2go.org> Sat, 04 Jul 2015 06:29:19 +0200
nx-libs (2:3.5.0.32-0x2go1) unstable; urgency=low
diff --git a/debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch b/debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch
new file mode 100644
index 000000000..aceea8f43
--- /dev/null
+++ b/debian/patches/1301_nxcomp_Reduce-TokenSize-slightly-for.full+lite.patch
@@ -0,0 +1,34 @@
+From 418db3b5ce28bcc5b1d00d7444041ea2d6592706 Mon Sep 17 00:00:00 2001
+From: Simon Matter <simon.matter@invoca.ch>
+Date: Mon, 9 Oct 2017 11:30:02 +0200
+Subject: [PATCH] nxcomp/src/Loop.cpp: Reduce control->TokenSize slightly again
+ in order to fix fragmentation of packages when on VPN (or otherwise
+ encapsulated) connections.
+
+ Backported from Arctica GH 3.6.x branch.
+
+ v2: backport to nx-libs 3.5.0.x (Mihai Moldovan)
+---
+ nxcomp/src/Loop.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/nxcomp/Loop.cpp
++++ b/nxcomp/Loop.cpp
+@@ -13017,7 +13017,7 @@ int SetLinkAdsl()
+
+ control -> LinkMode = LINK_TYPE_ADSL;
+
+- control -> TokenSize = 1536;
++ control -> TokenSize = 1408;
+ control -> TokenLimit = 24;
+
+ control -> SplitMode = 1;
+@@ -13047,7 +13047,7 @@ int SetLinkWan()
+
+ control -> LinkMode = LINK_TYPE_WAN;
+
+- control -> TokenSize = 1536;
++ control -> TokenSize = 1408;
+ control -> TokenLimit = 24;
+
+ control -> SplitMode = 1;