aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-08-20 13:02:53 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-08-20 13:07:58 +0200
commitc9bc8accc1b1a385b61c1a802da99c4de3d4577c (patch)
treeaa6d96362da0a13bc53a88ac87be3e9182d55558 /debian
parent0e3b414ea6ecb6cc359d3b95f5cfeb6096066139 (diff)
downloadnx-libs-c9bc8accc1b1a385b61c1a802da99c4de3d4577c.tar.gz
nx-libs-c9bc8accc1b1a385b61c1a802da99c4de3d4577c.tar.bz2
nx-libs-c9bc8accc1b1a385b61c1a802da99c4de3d4577c.zip
Add 025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch. Fix FTBFS when built against libjpeg9a. Thanks to Gabriel Marcano for sending this in.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch40
-rw-r--r--debian/patches/series1
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 59028adb5..2c4193746 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
nx-libs (2:3.5.0.28-0x2go1) UNRELEASED; urgency=medium
* Provide COPYING file in tarball. Update debian/copyright.
+ * Add 025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch. Fix FTBFS when
+ built against libjpeg9a. Thanks to Gabriel Marcano for sending this in.
+ (Fixes: #578).
-- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Mon, 30 Jun 2014 15:05:54 +0200
diff --git a/debian/patches/025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch b/debian/patches/025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch
new file mode 100644
index 000000000..66ca8c33e
--- /dev/null
+++ b/debian/patches/025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch
@@ -0,0 +1,40 @@
+Description: Fix FTBFS when built against libjpeg9a
+Author: Gabriel Marcano <gabemarcano@yahoo.com>
+--- a/nxcomp/Jpeg.cpp 2014-08-19 22:23:36.139072400 -0400
++++ b/nxcomp/Jpeg.cpp 2014-08-19 22:25:24.323182800 -0400
+@@ -440,7 +440,7 @@
+
+ JpegSetSrcManager(&cinfo, compressedData, compressedLen);
+
+- jpeg_read_header(&cinfo, 1);
++ jpeg_read_header(&cinfo, TRUE);
+
+ if (jpegError) goto AbortDecompressJpeg16;
+
+@@ -581,7 +581,7 @@
+
+ JpegSetSrcManager(&cinfo, compressedData, compressedLen);
+
+- jpeg_read_header(&cinfo, 1);
++ jpeg_read_header(&cinfo, TRUE);
+
+ if (jpegError) goto AbortDecompressJpeg24;
+
+@@ -718,7 +718,7 @@
+
+ JpegSetSrcManager(&cinfo, compressedData, compressedLen);
+
+- jpeg_read_header(&cinfo, 1);
++ jpeg_read_header(&cinfo, TRUE);
+
+ if (jpegError) goto AbortDecompressJpeg32;
+
+@@ -833,7 +833,7 @@
+ jpegSrcManager.bytes_in_buffer = jpegBufferLen;
+ jpegSrcManager.next_input_byte = (JOCTET *)jpegBufferPtr;
+
+- return 1;
++ return TRUE;
+ }
+
+ static void JpegSkipInputData(j_decompress_ptr cinfo, long num_bytes)
diff --git a/debian/patches/series b/debian/patches/series
index cf3e9a001..e23de8ded 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -19,6 +19,7 @@
019_nx-X11_expat-build-against-system-libxmltok.full.patch
024_fix-make-clean.full.patch
024_fix-make-clean.full+lite.patch
+025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch
026_nxcompext_honour-optflags.full.patch
026_nxcomp_honour-optflags.full+lite.patch
026_nxcompshad_honour-optflags.full.patch