aboutsummaryrefslogtreecommitdiff
path: root/nx-X11/lib/Xfixes/Makefile.am
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2011-10-10 17:43:39 +0200
committerReinhard Tartler <siretart@tauware.de>2011-10-10 17:43:39 +0200
commitf4092abdf94af6a99aff944d6264bc1284e8bdd4 (patch)
tree2ac1c9cc16ceb93edb2c4382c088dac5aeafdf0f /nx-X11/lib/Xfixes/Makefile.am
parenta840692edc9c6d19cd7c057f68e39c7d95eb767d (diff)
downloadnx-libs-f4092abdf94af6a99aff944d6264bc1284e8bdd4.tar.gz
nx-libs-f4092abdf94af6a99aff944d6264bc1284e8bdd4.tar.bz2
nx-libs-f4092abdf94af6a99aff944d6264bc1284e8bdd4.zip
Imported nx-X11-3.1.0-1.tar.gznx-X11/3.1.0-1
Summary: Imported nx-X11-3.1.0-1.tar.gz Keywords: Imported nx-X11-3.1.0-1.tar.gz into Git repository
Diffstat (limited to 'nx-X11/lib/Xfixes/Makefile.am')
-rw-r--r--nx-X11/lib/Xfixes/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/nx-X11/lib/Xfixes/Makefile.am b/nx-X11/lib/Xfixes/Makefile.am
new file mode 100644
index 000000000..08598f93e
--- /dev/null
+++ b/nx-X11/lib/Xfixes/Makefile.am
@@ -0,0 +1,56 @@
+#
+# $Id: Makefile.am,v 1.1 2004/07/31 05:50:39 anholt Exp $
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+AM_CFLAGS = $(FIXESEXT_CFLAGS) $(X_CFLAGS)
+
+lib_LTLIBRARIES = libXfixes.la
+
+libXfixes_la_SOURCES = \
+ Cursor.c \
+ Region.c \
+ SaveSet.c \
+ Selection.c \
+ Xfixes.c \
+ Xfixesint.h
+
+libXfixes_la_LIBADD = @X_LIBS@
+
+#
+# Library version info. Check the libtool docs for
+# instructions on when and how to change this value
+#
+# bump when the ABI changes
+XFIXES_CURRENT=2
+# bump for non-ABI changes, reset to zero when CURRENT changes
+XFIXES_REVISION=0
+# bump when the ABI changes in backward-compatible fashion
+XFIXES_AGE=2
+libXfixes_la_LDFLAGS = -version-info ${XFIXES_CURRENT}:${XFIXES_REVISION}:${XFIXES_AGE} -no-undefined
+
+libXfixesincludedir = $(includedir)/X11/extensions
+libXfixesinclude_HEADERS = Xfixes.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xfixes.pc
+
+EXTRA_DIST = xfixes.pc.in autogen.sh