aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/test/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-27 11:12:00 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-27 11:12:00 +0200
commitde3d9ff4ee51f3f9125d4a76cc21747c0613b8fd (patch)
treeb2abe728e91199b50c25732da22b1e623b395b5b /nxcomp/test/Makefile.am
parent39ee56f5dbe968cddebf6e7891667a2cf8b5af76 (diff)
parentceac077637d147b54abeeb4f0154bf152ba13138 (diff)
downloadnx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.tar.gz
nx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.tar.bz2
nx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.zip
Merge branch 'theqvd-improved-logging' into 3.6.x
Attributes GH PR #193: https://github.com/ArcticaProject/nx-libs/pull/193
Diffstat (limited to 'nxcomp/test/Makefile.am')
-rw-r--r--nxcomp/test/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/nxcomp/test/Makefile.am b/nxcomp/test/Makefile.am
new file mode 100644
index 000000000..412b8ea94
--- /dev/null
+++ b/nxcomp/test/Makefile.am
@@ -0,0 +1,22 @@
+NULL =
+
+noinst_PROGRAMS = logging_test
+EXTRA_DIST = logging_test
+
+AM_CPPFLAGS = -I$(top_srcdir)/src
+AM_CXXFLAGS = \
+ @PTHREAD_CFLAGS@ \
+ $(NULL)
+
+logging_test_SOURCES = logging_test.cpp
+logging_test_LDADD = \
+ $(top_srcdir)/src/.libs/libXcomp.a \
+ @PTHREAD_LIBS@ \
+ $(NULL)
+
+logging_test_LDFLAGS = \
+ $(PTHREAD_LDFLAGS) \
+ $(NULL)
+
+check: all
+ ./logging_test