aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-27 11:12:00 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-27 11:12:00 +0200
commitde3d9ff4ee51f3f9125d4a76cc21747c0613b8fd (patch)
treeb2abe728e91199b50c25732da22b1e623b395b5b /nxcompshad/configure.ac
parent39ee56f5dbe968cddebf6e7891667a2cf8b5af76 (diff)
parentceac077637d147b54abeeb4f0154bf152ba13138 (diff)
downloadnx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.tar.gz
nx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.tar.bz2
nx-libs-de3d9ff4ee51f3f9125d4a76cc21747c0613b8fd.zip
Merge branch 'theqvd-improved-logging' into 3.6.x
Attributes GH PR #193: https://github.com/ArcticaProject/nx-libs/pull/193
Diffstat (limited to 'nxcompshad/configure.ac')
-rw-r--r--nxcompshad/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/nxcompshad/configure.ac b/nxcompshad/configure.ac
index 34b1c053c..966add584 100644
--- a/nxcompshad/configure.ac
+++ b/nxcompshad/configure.ac
@@ -44,6 +44,12 @@ AC_LANG([C++])
NX_COMPILER_BRAND
NX_DEFAULT_OPTIONS
+AC_ARG_ENABLE([cxx11],
+ [AS_HELP_STRING([--enable-cxx11],
+ [enable optional features requiring C++11 support (disabled by default)])],
+ [AS_IF([test x$enableval = xyes],
+ [AX_CXX_COMPILE_STDCXX_11([], [mandatory])])])
+
AC_CONFIG_FILES([
Makefile
src/Makefile