aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.in
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2015-03-16 03:29:16 +0100
committerMihai Moldovan <ionic@ionic.de>2015-03-16 03:29:16 +0100
commitd8de5928e1e7a0677ed2d38fa4d9f53a58514ebe (patch)
treefcdefeeaa0b2484ea747a3d74891203a39689c05 /nxcompshad/configure.in
parent638e31c2f33723123d35ce65db88071a1be5cdb0 (diff)
downloadnx-libs-d8de5928e1e7a0677ed2d38fa4d9f53a58514ebe.tar.gz
nx-libs-d8de5928e1e7a0677ed2d38fa4d9f53a58514ebe.tar.bz2
nx-libs-d8de5928e1e7a0677ed2d38fa4d9f53a58514ebe.zip
nx{comp{,ext,shad},proxy}: try really hard to find makedepend. Do not fail if it is not available.
Diffstat (limited to 'nxcompshad/configure.in')
-rw-r--r--nxcompshad/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/nxcompshad/configure.in b/nxcompshad/configure.in
index 4e91361ff..8dd1b2e21 100644
--- a/nxcompshad/configure.in
+++ b/nxcompshad/configure.in
@@ -271,4 +271,14 @@ dnl Find makedepend somewhere.
AC_SUBST(MAKEDEPEND)
MAKEDEPEND="$(which makedepend)"
+# Try to desperately find makedepend.
+# Set MAKEDEPEND to the shipped makedepend binary. This will not
+# exist in nx-libs-lite, though, in which case MAKEDEPEND
+# will stay empty.
+if test -z "${MAKEDEPEND}"; then
+ if test -x "../nx-X11/config/makedepend/makedepend"; then
+ MAKEDEPEND="../nx-X11/config/makedepend/makedepend"
+ fi
+fi
+
AC_OUTPUT(Makefile)