aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-02-25 15:03:52 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-02-25 15:03:52 +0100
commita653aed4c0f0c83185fca8076559ae10553ec11f (patch)
treedc732ad657d21942d1d964763ab301a2672299f3 /nxproxy/src/Makefile.am
parentdd1ae1769858b7467bd4cde2b83b1cda8653c983 (diff)
parent06c14b83184f30498e27fed435d38d6e33338f2c (diff)
downloadnx-libs-a653aed4c0f0c83185fca8076559ae10553ec11f.tar.gz
nx-libs-a653aed4c0f0c83185fca8076559ae10553ec11f.tar.bz2
nx-libs-a653aed4c0f0c83185fca8076559ae10553ec11f.zip
Merge branch 'Ionic-bugfix/FTBFS-non-ELF' into 3.6.x
Attributes GH PR #663: https://github.com/ArcticaProject/nx-libs/pull/663
Diffstat (limited to 'nxproxy/src/Makefile.am')
-rw-r--r--nxproxy/src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/nxproxy/src/Makefile.am b/nxproxy/src/Makefile.am
index ecf2a0486..fbe52cbf8 100644
--- a/nxproxy/src/Makefile.am
+++ b/nxproxy/src/Makefile.am
@@ -15,8 +15,13 @@ nxproxy_LDADD = \
nxproxy_LDFLAGS = \
$(PTHREAD_LDFLAGS) \
+ $(NULL)
+
+if TARGET_ELF
+nxproxy_LDFLAGS += \
-Wl,--enable-new-dtags \
$(NULL)
+endif TARGET_ELF
nxproxy_CFLAGS = \
$(BASE_CFLAGS) \