aboutsummaryrefslogtreecommitdiff
path: root/debian/Makefile.nx-libs
diff options
context:
space:
mode:
Diffstat (limited to 'debian/Makefile.nx-libs')
-rw-r--r--debian/Makefile.nx-libs15
1 files changed, 12 insertions, 3 deletions
diff --git a/debian/Makefile.nx-libs b/debian/Makefile.nx-libs
index 45ea8a958..884787742 100644
--- a/debian/Makefile.nx-libs
+++ b/debian/Makefile.nx-libs
@@ -42,9 +42,18 @@ build-lite:
build-full:
# in the full case, we rely on "magic" in the nx-X11 imake-based makefiles...
- cd nxcomp && autoconf
- cd nxcompext && autoconf
- cd nxcompshad && autoconf
+ cd nxcomp && autoconf && (${CONFIGURE}) && ${MAKE}
+
+ # prepare Makefiles and the nx-X11 symlinking magic
+ cd nx-X11 && make BuildEnv
+
+ # build libNX_X11 and libNX_Xext prior to building
+ # nxcomp{ext,shad}.
+ cd nx-X11/lib && make
+
+ cd nxcompext && autoconf && (${CONFIGURE}) && ${MAKE}
+ cd nxcompshad && autoconf && (${CONFIGURE}) && ${MAKE}
+
cd nx-X11 && ${MAKE} World
cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}