aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch')
-rw-r--r--debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch b/debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch
new file mode 100644
index 000000000..4e92c3b04
--- /dev/null
+++ b/debian/patches/0002_nxcompshad_build-against-nx-x11-only.full.patch
@@ -0,0 +1,39 @@
+Description: Build nxcompshad against nx-X11.
+ Make sure nxcompshad get built against nx-X11.
+ .
+ Furthermore /usr/X11R6/lib is an outdated path on
+ current Debian systems.
+Forwarded: pending...
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Last-Update: 2011-12-31
+--- a/nxcompshad/Makefile.in
++++ b/nxcompshad/Makefile.in
+@@ -48,7 +48,7 @@
+ CCDEFINES =
+
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ -L/usr/X11R6/lib -lX11
++LIBS = @LIBS@ -lX11
+
+ #
+ # Only if THREADS is defined.
+@@ -162,7 +162,7 @@
+ -Wl,--enable-auto-import \
+ -Wl,--whole-archive ${LIBARCHIVE} \
+ -Wl,--no-whole-archive \
+- ${LIBS} -L/usr/X11R6/lib
++ ${LIBS}
+
+ $(PROGRAM): $(MOBJ) $(COBJ) $(CXXOBJ) $(LIBDLL)
+ # $(CC) $(CCFLAGS) -o $@ $(MOBJ) $(MLIBS)
+--- a/nxcompshad/configure.in
++++ b/nxcompshad/configure.in
+@@ -19,7 +19,7 @@
+
+ if test -d "../nx-X11/exports/include" ; then
+ CXXFLAGS="$CXXFLAGS -I../nx-X11/exports/include"
+- LIBS="$LIBS -L../nx-X11/exports/lib"
++ LIBS="-L../nx-X11/exports/lib"
+ fi
+
+ dnl Check whether --with-ipaq was given.