aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/001_add-main-makefile.full+lite.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/001_add-main-makefile.full+lite.patch')
-rw-r--r--debian/patches/001_add-main-makefile.full+lite.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/patches/001_add-main-makefile.full+lite.patch b/debian/patches/001_add-main-makefile.full+lite.patch
new file mode 100644
index 000000000..fffa4dc42
--- /dev/null
+++ b/debian/patches/001_add-main-makefile.full+lite.patch
@@ -0,0 +1,44 @@
+Description: Provide main Makefile for whole source tree
+ By design this patch is not needed to be sent upstream.
+Forwarded: not-needed
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Last-Update: 2011-12-31
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,36 @@
++#!/usr/bin/make -f
++
++CONFIGURE=./configure
++
++%:
++ if test -f nxcomp/Makefile; then ${MAKE} -C nxcomp $@; fi
++ if test -f nxproxy/Makefile; then ${MAKE} -C nxproxy $@; fi
++ if test -d nx-X11; then \
++ if test -f nxcompext/Makefile; then ${MAKE} -C nxcompext $@; fi; \
++ if test -f nxcompshad/Makefile; then ${MAKE} -C nxcompshad $@; fi; \
++ if test -f nx-X11/Makefile; then ${MAKE} -C nx-X11 $@; fi; \
++ fi
++
++all: build
++
++test:
++ echo "No testing for NX (redistributed)"
++
++build-lite:
++ cd nxcomp && autoconf && (${CONFIGURE}) && ${MAKE}
++ cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}
++
++build-full:
++# in the full case, we rely on "magic" in the nx-X11 imake-based makefiles...
++ cd nxcomp && autoconf
++ cd nxcompext && autoconf
++ cd nxcompshad && autoconf
++ cd nx-X11 && ${MAKE} World
++ cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}
++
++build:
++ if ! test -d nx-X11; then \
++ ${MAKE} build-lite; \
++ else \
++ ${MAKE} build-full; \
++ fi