aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/001_add-main-makefile.full+lite.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/001_add-main-makefile.full+lite.patch')
-rw-r--r--debian/patches/001_add-main-makefile.full+lite.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/patches/001_add-main-makefile.full+lite.patch b/debian/patches/001_add-main-makefile.full+lite.patch
index 3c236b9f2..fffa4dc42 100644
--- a/debian/patches/001_add-main-makefile.full+lite.patch
+++ b/debian/patches/001_add-main-makefile.full+lite.patch
@@ -11,12 +11,12 @@ Last-Update: 2011-12-31
+CONFIGURE=./configure
+
+%:
-+ ${MAKE} -C nxcomp $@
-+ ${MAKE} -C nxproxy $@
++ if test -f nxcomp/Makefile; then ${MAKE} -C nxcomp $@; fi
++ if test -f nxproxy/Makefile; then ${MAKE} -C nxproxy $@; fi
+ if test -d nx-X11; then \
-+ ${MAKE} -C nxcompext $@; \
-+ ${MAKE} -C nxcompshad; \
-+ ${MAKE} -C nx-X11 $@; \
++ if test -f nxcompext/Makefile; then ${MAKE} -C nxcompext $@; fi; \
++ if test -f nxcompshad/Makefile; then ${MAKE} -C nxcompshad $@; fi; \
++ if test -f nx-X11/Makefile; then ${MAKE} -C nx-X11 $@; fi; \
+ fi
+
+all: build