aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/001_add-main-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/001_add-main-makefile.patch')
-rw-r--r--debian/patches/001_add-main-makefile.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/001_add-main-makefile.patch b/debian/patches/001_add-main-makefile.patch
new file mode 100644
index 000000000..f487ef711
--- /dev/null
+++ b/debian/patches/001_add-main-makefile.patch
@@ -0,0 +1,46 @@
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,43 @@
++#!/usr/bin/make -f
++
++all: build
++
++build: build-arch build-indep
++
++clean:
++ cd nx-X11 && test -f Makefile && make $@ || true
++ cd nxcomp && test -f Makefile && make $@ || true
++ cd nxcompext && test -f Makefile && make $@ || true
++ cd nxcompshad && test -f Makefile && make $@ || true
++ cd nxproxy && test -f Makefile && make $@ || true
++
++
++distclean:
++ cd nx-X11 && test -f Makefile && make $@ || true
++ cd nxcomp && test -f Makefile && make $@ || true
++ cd nxcompext && test -f Makefile && make $@ || true
++ cd nxcompshad && test -f Makefile && make $@ || true
++ cd nxproxy && test -f Makefile && make $@ || true
++
++build-arch:
++ cd nxcomp && autoconf
++ cd nxcompext && autoconf
++ cd nxcompshad && autoconf
++ cd nx-X11 && make World
++ cd nxproxy && autoconf && ./configure && make
++
++build-indep:
++
++install:
++ cd nxcomp && make install
++ cd nxcompext && make install
++ cd nxcompshad && make install
++ cd nx-X11 && make install
++ cd nxproxy && make install
++
++uninstall:
++ cd nxcomp && make uninstall
++ cd nxcompext && make uninstall
++ cd nxcompshad && make uninstall
++ cd nx-X11 && make uninstall
++ cd nxproxy && make uninstall