aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/013_nxcompext-makefile-uninstall.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/013_nxcompext-makefile-uninstall.patch')
-rw-r--r--debian/patches/013_nxcompext-makefile-uninstall.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/debian/patches/013_nxcompext-makefile-uninstall.patch b/debian/patches/013_nxcompext-makefile-uninstall.patch
new file mode 100644
index 000000000..f4002a565
--- /dev/null
+++ b/debian/patches/013_nxcompext-makefile-uninstall.patch
@@ -0,0 +1,50 @@
+Index: nx-libs/nxcompext/Makefile.in
+===================================================================
+--- nx-libs.orig/nxcompext/Makefile.in 2011-12-05 09:20:15.000000000 +0100
++++ nx-libs/nxcompext/Makefile.in 2011-12-05 09:24:37.000000000 +0100
+@@ -60,7 +60,9 @@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+-
++INSTALL_LINK = cp -av
++DESTDIR =
++RM_FILE = rm -f
+ #
+ # This should be autodetected.
+ #
+@@ -147,12 +149,33 @@
+ fi
+ touch depend.status
+
+-install: install.bin install.man
++install: install.bin install.lib install.man
+
+ install.bin:
+
++install.lib: all
++ ./mkinstalldirs $(DESTDIR)$(prefix)/lib/nx
++ ./mkinstalldirs $(DESTDIR)$(prefix)/include/nx
++ $(INSTALL_DATA) libXcompext.so.* $(DESTDIR)$(prefix)/lib/nx
++ $(INSTALL_LINK) libXcompext.so $(DESTDIR)$(prefix)/lib/nx
++ $(INSTALL_DATA) NX*.h $(DESTDIR)$(prefix)/include/nx
++ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
++
+ install.man:
+
++uninstall: uninstall.bin uninstall.lib uninstall.man
++
++uninstall.bin:
++
++uninstall.lib:
++ $(RM_FILE) $(DESTDIR)$(prefix)/lib/nx/libXcompext.so.*
++ $(RM_FILE) $(DESTDIR)$(prefix)/lib/nx/libXcompext.so
++ $(RM_FILE) $(DESTDIR)$(prefix)/include/nx/NXlib.h
++ $(RM_FILE) $(DESTDIR)$(prefix)/include/nx/NXlibint.h
++ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
++
++uninstall.man:
++
+ clean:
+ -rm -f *~ *.o *.bak *.orig *.rej st?????? core core.* *.out.* \
+ @ALL@