aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/016_nx-X11_install-location.full.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/016_nx-X11_install-location.full.patch')
-rw-r--r--debian/patches/016_nx-X11_install-location.full.patch122
1 files changed, 122 insertions, 0 deletions
diff --git a/debian/patches/016_nx-X11_install-location.full.patch b/debian/patches/016_nx-X11_install-location.full.patch
index 0231bcba7..6571aea9e 100644
--- a/debian/patches/016_nx-X11_install-location.full.patch
+++ b/debian/patches/016_nx-X11_install-location.full.patch
@@ -30,3 +30,125 @@ Last-Update: 2012-12-31
#ifndef AlternateIncRoot
#define AlternateIncRoot YES
#endif
+--- a/nx-X11/config/cf/X11.rules
++++ b/nx-X11/config/cf/X11.rules
+@@ -36,17 +36,17 @@
+ #endif
+
+ #if defined(X11ProjectRoot)
+-# define XBinDir $(XPROJECTROOT)/bin
++# define XBinDir $(XPROJECTROOT)/lib/nx/bin
+ #elif defined(ProjectRoot)
+-# define XBinDir $(PROJECTROOT)/bin
++# define XBinDir $(PROJECTROOT)/lib/nx/bin
+ #else
+ # define XBinDir $(BINDIR)
+ #endif
+
+ #ifdef X11ProjectRoot
+-# define XUsrLibDirPath $(USRLIBDIR):$(XPROJECTROOT)/lib
++# define XUsrLibDirPath $(USRLIBDIR)/nx:$(XPROJECTROOT)
+ #else
+-# define XUsrLibDirPath $(USRLIBDIR)
++# define XUsrLibDirPath $(USRLIBDIR)/nx
+ #endif
+ #ifdef UsrLibDirPath
+ # undef UsrLibDirPath
+@@ -60,7 +60,7 @@
+ #if ImportX11
+ # define XLdPreLibs -L$(LIBSRC)
+ #elif defined(UseInstalledX11) && defined(X11ProjectRoot)
+-# define XLdPreLibs -L$(XPROJECTROOT)/lib
++# define XLdPreLibs -L$(XPROJECTROOT)
+ #else
+ # define XLdPreLibs /**/
+ #endif
+@@ -70,7 +70,7 @@
+ #define LdPreLibs LdPreLib XLdPreLibs
+
+ #ifdef X11ProjectRoot
+-# define XLdPostLibs -L$(XPROJECTROOT)/lib
++# define XLdPostLibs -L$(XPROJECTROOT)
+ #else
+ # define XLdPostLibs /**/
+ #endif
+@@ -86,7 +86,7 @@
+ # define TopXInclude -I$(TOP)/exports/include
+ #else
+ # ifdef X11ProjectRoot
+-# define TopXInclude -I$(XPROJECTROOT)/include
++# define TopXInclude -I$(XPROJECTROOT)/../../include/nx
+ # else
+ # define TopXInclude /**/
+ # endif
+@@ -98,7 +98,7 @@
+ #define TopIncludes TopInclude $(TOP_X_INCLUDES)
+
+ #if UseInstalledX11 && defined(X11ProjectRoot)
+-# define X11BuildLibPath $(XPROJECTROOT)/lib
++# define X11BuildLibPath $(XPROJECTROOT)
+ #elif UseInstalledX11
+ # define X11BuildLibPath $(USRLIBDIR)
+ #elif ImportX11
+--- a/nx-X11/config/cf/X11.tmpl
++++ b/nx-X11/config/cf/X11.tmpl
+@@ -1401,7 +1401,7 @@
+
+ #ifndef BinDir
+ #ifdef ProjectRoot
+-#define BinDir Concat(ProjectRoot,/bin)
++#define BinDir Concat(ProjectRoot,/lib/nx/bin)
+ #else
+ #define BinDir /usr/bin/X11
+ #endif
+@@ -1461,7 +1461,7 @@
+ #endif
+ #ifndef LibDir
+ # ifdef ProjectRoot
+-# define LibDir Concat(ProjectRoot,/lib/X11)
++# define LibDir Concat(ProjectRoot,/lib/nx/X11)
+ # else
+ # define LibDir /usr/lib/X11
+ # endif
+--- a/nx-X11/config/cf/linux.cf
++++ b/nx-X11/config/cf/linux.cf
+@@ -1054,7 +1054,7 @@
+
+ #if HaveLib64
+ # ifndef LibDirName
+-# define LibDirName lib64
++# define LibDirName lib
+ # endif
+ # ifndef SystemUsrLibDir
+ # define SystemUsrLibDir /usr/lib64
+--- a/nx-X11/config/cf/site.def
++++ b/nx-X11/config/cf/site.def
+@@ -72,7 +72,7 @@
+ #ifdef AfterVendorCF
+
+ #ifndef ProjectRoot
+-#define ProjectRoot /usr/local/lib/nx
++#define ProjectRoot /usr/local
+ #endif
+
+ /*
+@@ -87,7 +87,7 @@
+ * ProjectRoot rather than in /etc/X11. See also HasVarDirectory,
+ * UseEtcX11 and UseSeparateConfDir.
+ *
+-#define EtcX11Directory ProjectRoot/etc
++#define EtcX11Directory /etc/nx
+ */
+
+
+--- a/nxproxy/Makefile.in
++++ b/nxproxy/Makefile.in
+@@ -33,7 +33,7 @@
+
+ srcdir = @srcdir@
+ prefix = @prefix@
+-exec_prefix = @exec_prefix@
++exec_prefix = @exec_prefix@/lib/nx
+ bindir = @bindir@
+ man1dir = @mandir@/man1
+ VPATH = @srcdir@