aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/031_nx-X11_parallel-make.full.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/031_nx-X11_parallel-make.full.patch')
-rw-r--r--debian/patches/031_nx-X11_parallel-make.full.patch129
1 files changed, 25 insertions, 104 deletions
diff --git a/debian/patches/031_nx-X11_parallel-make.full.patch b/debian/patches/031_nx-X11_parallel-make.full.patch
index 1bacd1ab3..e87918a71 100644
--- a/debian/patches/031_nx-X11_parallel-make.full.patch
+++ b/debian/patches/031_nx-X11_parallel-make.full.patch
@@ -9,19 +9,13 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
---
nx-X11/Makefile | 64 +++++++++++++++++-----------------
nx-X11/config/imake/Makefile.ini | 1
- nx-X11/extras/Mesa/Makefile | 2 -
- nx-X11/extras/Xpm/Makefile.noX | 1
- nx-X11/extras/drm/linux-core/Makefile | 4 +-
- nx-X11/extras/drm/linux/Makefile | 4 +-
- nx-X11/extras/ttf2pt1/Makefile | 4 +-
nx-X11/lib/X11/Imakefile | 12 ++----
- nx-X11/lib/X11/Imakefile.NX.original | 12 ++----
nx-X11/programs/Xserver/Imakefile | 4 +-
10 files changed, 60 insertions(+), 69 deletions(-)
--- a/nx-X11/Makefile
+++ b/nx-X11/Makefile
-@@ -32,8 +32,8 @@ VERSSRC = $(CONFIGSRC)/util/printver.c
+@@ -32,8 +32,8 @@
VERSPROG = $(CONFIGSRC)/util/printver.exe
all:
@@ -32,7 +26,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
all-initial:
@echo Please use make World, or on NT use nmake World.Win32.
-@@ -57,8 +57,8 @@ World:
+@@ -57,8 +57,8 @@
@date
@echo ""
@if [ -f xmakefile ]; then \
@@ -43,7 +37,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
$(RM) xmakefile; \
fi
@if [ ! -f $(IRULESRC)/host.def ]; then \
-@@ -84,14 +84,14 @@ World:
+@@ -84,14 +84,14 @@
# fi
cd $(IMAKESRC) && $(MAKE) $(FLAGS) clean
$(MAKE) $(MFLAGS) Makefile.boot
@@ -65,7 +59,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
@echo ""
@date
@echo ""
-@@ -154,15 +154,15 @@ World.Win32:
+@@ -154,15 +154,15 @@
-if exist xmakefile.bak del xmakefile.bak
-if exist xmakefile ren xmakefile xmakefile.bak
$(IMAKE:/=\) -s xmakefile -I$(IRULESRC) $(IMAKE_DEFINES) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT_DIR)
@@ -87,7 +81,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
@echo :
@echo :
@echo Full build of $(RELEASE) complete.
-@@ -198,38 +198,38 @@ World.OS2:
+@@ -198,38 +198,38 @@
# a copy of every rule that might be invoked at top level
clean:
@@ -143,7 +137,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
+ ${MAKE} ${MAKE_OPTS} $@
--- a/nx-X11/config/imake/Makefile.ini
+++ b/nx-X11/config/imake/Makefile.ini
-@@ -21,7 +21,6 @@ IMAKEMDEP_CROSSCOMPILE = -DCROSSCOMPILE_
+@@ -21,7 +21,6 @@
SHELL = /bin/sh
RM = rm -f
MV = mv
@@ -151,83 +145,9 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
RM_CMD = $(RM) *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a \
tags TAGS make.log
NPROC = 1
---- a/nx-X11/extras/Mesa/Makefile
-+++ b/nx-X11/extras/Mesa/Makefile
-@@ -12,7 +12,7 @@ default: $(TOP)/configs/current
-
-
- doxygen:
-- (cd doxygen ; make) ; \
-+ (cd doxygen ; ${MAKE}) ; \
-
- clean:
- @for dir in $(SUBDIRS) ; do \
---- a/nx-X11/extras/Xpm/Makefile.noX
-+++ b/nx-X11/extras/Xpm/Makefile.noX
-@@ -32,7 +32,6 @@
-
- SUBDIRS= lib sxpm cxpm
-
--MAKE=make
- MFLAGS=-f Makefile.noX
- INSTALL= install -c
- CURRENT_DIR=.
---- a/nx-X11/extras/drm/linux-core/Makefile
-+++ b/nx-X11/extras/drm/linux-core/Makefile
-@@ -176,7 +176,7 @@ endif
- all: modules
-
- modules: includes
-- make -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-+ ${MAKE} -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-
- ifeq ($(HEADERFROMBOOT),1)
-
-@@ -246,7 +246,7 @@ clean cleandir:
- rm -rf $(CLEANFILES)
-
- $(MODULE_LIST)::
-- make DRM_MODULES=$@ modules
-+ ${MAKE} DRM_MODULES=$@ modules
-
- # Build test utilities
-
---- a/nx-X11/extras/drm/linux/Makefile
-+++ b/nx-X11/extras/drm/linux/Makefile
-@@ -184,7 +184,7 @@ endif
- all: modules
-
- modules: includes
-- make -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-+ ${MAKE} -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-
- ifeq ($(HEADERFROMBOOT),1)
-
-@@ -254,7 +254,7 @@ clean cleandir:
- rm -rf $(CLEANFILES)
-
- $(MODULE_LIST)::
-- make DRM_MODULES=$@ modules
-+ ${MAKE} DRM_MODULES=$@ modules
-
- # Build test utilities
-
---- a/nx-X11/extras/ttf2pt1/Makefile
-+++ b/nx-X11/extras/ttf2pt1/Makefile
-@@ -158,8 +158,8 @@ mans: $(MANS)
-
- clean:
- rm -f t1asm ttf2pt1 *.o app/RPM/Makefile app/RPM/*.spec *.core core.* core
-- ( cd other && make clean; )
-- ( cd app/netscape && make clean; )
-+ ( cd other && ${MAKE} clean; )
-+ ( cd app/netscape && ${MAKE} clean; )
-
- veryclean: clean
- rm -f $(DOCS) $(MANS)
--- a/nx-X11/lib/X11/Imakefile
+++ b/nx-X11/lib/X11/Imakefile
-@@ -1161,25 +1161,23 @@ $(NX_XCOMPEXTCONFIGTARGET):
+@@ -1161,25 +1161,23 @@
#ifdef SunArchitecture
$(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
@@ -261,9 +181,26 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
all:: $(NX_XCOMPLIBTARGET)
+--- a/nx-X11/programs/Xserver/Imakefile
++++ b/nx-X11/programs/Xserver/Imakefile
+@@ -1045,11 +1045,11 @@
+ #ifdef SunArchitecture
+ $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
+ cd $(NX_XSHADOWLIBDIR) && \
+- gmake
++ ${MAKE}
+ #else
+ $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
+ cd $(NX_XSHADOWLIBDIR) && \
+- rm -f *.o && make
++ rm -f *.o && ${MAKE}
+ #endif
+
+ ServerTarget(nxagent,$(NX_XSHADOWLIBTARGET) $(NXAGENTDIRS),$(NXAGENTOBJS), \
+
--- a/nx-X11/lib/X11/Imakefile.NX.original
+++ b/nx-X11/lib/X11/Imakefile.NX.original
-@@ -1159,21 +1159,17 @@ $(NX_XCOMPEXTCONFIGTARGET):
+@@ -1159,21 +1159,17 @@
#ifdef SunArchitecture
$(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
@@ -289,19 +226,3 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
#endif
---- a/nx-X11/programs/Xserver/Imakefile
-+++ b/nx-X11/programs/Xserver/Imakefile
-@@ -1045,11 +1045,11 @@ $(NX_XSHADOWCONFIGTARGET):
- #ifdef SunArchitecture
- $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
- cd $(NX_XSHADOWLIBDIR) && \
-- gmake
-+ ${MAKE}
- #else
- $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
- cd $(NX_XSHADOWLIBDIR) && \
-- rm -f *.o && make
-+ rm -f *.o && ${MAKE}
- #endif
-
- ServerTarget(nxagent,$(NX_XSHADOWLIBTARGET) $(NXAGENTDIRS),$(NXAGENTOBJS), \