aboutsummaryrefslogtreecommitdiff
path: root/debian/roll-tarballs.sh
diff options
context:
space:
mode:
Diffstat (limited to 'debian/roll-tarballs.sh')
-rwxr-xr-xdebian/roll-tarballs.sh20
1 files changed, 12 insertions, 8 deletions
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index 2dc1c8942..fd36b281d 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -111,10 +111,18 @@ for f in $(ls README* 2>/dev/null); do
done
mkdir -p bin/
-# old releases introude the wrappers via quilt patch
-for w in $(ls debian/wrappers/* 2>/dev/null); do
- cp -v $w bin/
-done
+if [ "$MODE" = "lite" ]; then
+ # copy wrapper script nxproxy only into tarball
+ cp -v debian/wrappers/nxproxy bin/
+else
+ # copy wrapper scripts into tarball
+ for w in $(ls debian/wrappers/* 2>/dev/null); do
+ cp -v $w bin/
+ done
+ # provide a default keystrokes.cfg file
+ mkdir -p etc
+ test -f etc/keystrokes.cfg || test -f debian/keystrokes.cfg && cp -v debian/keystrokes.cfg etc/keystrokes.cfg
+fi
mv -v debian/changelog doc/changelog
@@ -122,10 +130,6 @@ mv -v debian/changelog doc/changelog
test -f Makefile || test -f debian/Makefile.nx-libs && cp -v debian/Makefile.nx-libs Makefile
test -f replace.sh || test -f debian/Makefile.replace.sh && cp -v debian/Makefile.replace.sh replace.sh
-# provide a default keystrokes.cfg file
-mkdir -p etc
-test -f etc/keystrokes.cfg || test -f debian/keystrokes.cfg && cp -v debian/keystrokes.cfg etc/keystrokes.cfg
-
# remove folders that we do not want to roll into the tarball
rm -Rf ".pc/"
rm -Rf "debian/"