aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 6 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index cbc44ea00..c1f02946d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,10 +20,12 @@ override_dh_clean:
rm -f nx*/changelog
rm -f nx-X11/programs/Xserver/hw/nxagent/changelog
rm -f nx-X11/programs/nxauth/changelog
- rm -f Makefile
- rm -f bin
+ rm -f Makefile bin rgb VERSION.x2goagent
dh_clean
+override_dh_auto_install:
+ PREFIX=/usr dh_auto_install -Smakefile
+
override_dh_auto_build:
# create copies of upstream changelogs so that names apply to Debian policy...
cp -a nx-X11/CHANGELOG nx-X11/changelog
@@ -35,10 +37,10 @@ override_dh_auto_build:
cp -a nxproxy/CHANGELOG nxproxy/changelog
ln -s debian/Makefile.nx-libs Makefile
ln -s debian/wrappers bin
+ ln -s debian/rgb
+ ln -s debian/VERSION.x2goagent
LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh_auto_build --with quilt --parallel
debian/post-build-nx.sh
-override_dh_auto_install:
-
override_dh_strip:
dh_strip --dbg-package=nx-x11-dbg