aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index cbd600ab2..79ca44fc4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,14 @@ override_dh_clean:
dh_clean
override_dh_auto_build:
- debian/pre-build-nx.sh
+ # create copies of upstream changelogs so that names apply to Debian policy...
+ cp -a nx-X11/CHANGELOG nx-X11/changelog
+ cp -a nxcomp/CHANGELOG nxcomp/changelog
+ cp -a nxcompext/CHANGELOG nxcompext/changelog
+ cp -a nxcompshad/CHANGELOG nxcompshad/changelog
+ cp -a nx-X11/programs/Xserver/hw/nxagent/CHANGELOG nx-X11/programs/Xserver/hw/nxagent/changelog
+ cp -a nx-X11/programs/nxauth/CHANGELOG nx-X11/programs/nxauth/changelog
+ cp -a nxproxy/CHANGELOG nxproxy/changelog
LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh_auto_build --with quilt
debian/post-build-nx.sh