aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules51
1 files changed, 51 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..a5ac09e06
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,51 @@
+#!/usr/bin/make -f
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+%:
+ LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh $@ --with quilt
+
+override_dh_auto_clean:
+ rm -Rf nx-X11/.build-exports
+ LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh_auto_clean
+
+override_dh_clean:
+ rm -f nxcomp/configure
+ rm -f nxcompext/configure
+ rm -f nxcompshad/configure
+ rm -f nx-X11/changelog
+ rm -f nxcomp/changelog
+ rm -f nxcompext/changelog
+ rm -f nxcompshad/changelog
+ rm -f nx-X11/programs/Xserver/hw/nxagent/changelog
+ rm -f nx-X11/programs/nxauth/changelog
+ rm -f nxproxy/changelog
+ dh_clean
+
+override_dh_auto_build:
+ debian/pre-build-nx.sh
+ LD_LIBRARY_PATH=`pwd`/debian/libnx-x11/usr/lib/nx/X11:$$LD_LIBRARY_PATH dh_auto_build --with quilt --parallel
+ debian/post-build-nx.sh
+
+override_dh_auto_install:
+
+override_dh_quilt_patch:
+ dh_quilt_patch
+
+override_dh_quilt_unpatch:
+ dh_quilt_unpatch
+
+#override_dh_strip:
+# dh_strip -plibnx-x11 --dbg-package=libnx-x11-dbg
+# dh_strip -plibxcomp3 --dbg-package=libxcomp-dbg
+# dh_strip -plibxcompext3 --dbg-package=libxcompext-dbg
+# dh_strip -plibxcompshad3 --dbg-package=libxcompshad-dbg
+# dh_strip -pnxagent --dbg-package=nxagent-dbg
+#
+#.PHONY: override_dh_strip