aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog31
-rw-r--r--debian/control8
-rwxr-xr-xdebian/roll-tarballs.sh25
3 files changed, 54 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 0d56a4b96..17820e3d9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -243,6 +243,37 @@ nx-libs (2:3.5.0.32-0x2go1) UNRELEASED; urgency=low
Adds:
- 0992_fix-DEBUG-TEST-DUMP-FLUSH-TOKEN-PING-et-al-builds.full+lite.patch
+ [ Vadim Troshchinskiy ]
+ * nxcomp: fix "negotiation in stage 10" error.
+ v2: backport to nx-libs 3.5.0.x (Mihai Moldovan)
+ Adds:
+ - 0660_nxcomp_fix-negotiation-in-stage-10-error.full+lite.patch
+
+ [ Emanuele Giaquinta ]
+ * nx-X11: Fix alpha premultiplication in XRenderParseColor.
+ Fixes: #893.
+ v2: backport to nx-libs 3.6.x (Mike Gabriel)
+ v3: backport to nx-libs 3.5.0.x (Mihai Moldovan)
+ Adds:
+ - 0040_nx-X11_Fix-alpha-premultiplication-in-XRenderPa.full.patch
+
+ [ Michael DePaulo ]
+ * {nx-X11,nxproxy}: correct manpages: --help -> -help
+ xorg-server does not follow the convention of using 2 dashes.
+ Note that --help does produce the help output. However, it
+ produces this additional output after it:
+ Error: Aborting session with 'Unrecognized option: --help'.
+ Session: Aborting session at 'Sun Jun 28 01:35:35 2015'.
+ Session: Session aborted at 'Sun Jun 28 01:35:35 2015'.
+ It also causes a return code of 1 rather than 0.
+ Therefore, we should instruct users to call -help instead.
+
+ v2: backport to nx-libs 3.5.0.x (Mihai Moldovan)
+ Affects:
+ - 0009_nxagent_add-man-page.full.patch
+ - 0009_nxproxy_add-man-page.full+lite.patch
+ - 0209_x2goagent_add-man-page.full.patch
+
-- X2Go Release Manager <git-admin@x2go.org> Tue, 17 Mar 2015 19:19:32 +0100
nx-libs (2:3.5.0.31-0x2go1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 485c6fe0e..08e260a8b 100644
--- a/debian/control
+++ b/debian/control
@@ -1022,6 +1022,8 @@ Description: X2Go agent
Package: nxproxy
Architecture: any
+Breaks: qvd-nxproxy
+Replaces: qvd-nxproxy
Multi-Arch: foreign
Depends:
${shlibs:Depends},
@@ -1094,8 +1096,10 @@ Pre-Depends:
Depends:
${shlibs:Depends},
${misc:Depends},
-Breaks: nxcomp (<= 3.5.1)
-Replaces: nxcomp
+Breaks: nxcomp (<= 3.5.1),
+ qvd-libxcomp3,
+Replaces: nxcomp,
+ qvd-libxcomp3,
Description: nx-X11 compression library
NX is a software suite which implements very efficient
compression of the X11 protocol. This increases performance when
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index 954986b5f..ecaeac2e0 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -52,13 +52,13 @@ else
fi
if [ x"$RELEASE" == "xHEAD" ]; then
- CHECKOUT="HEAD"
+ CHECKOUT=refs/heads/$(git rev-parse --abbrev-ref HEAD)
fi
if ! git rev-parse --verify -q "$CHECKOUT" >/dev/null; then
echo " '${RELEASE}' is not a valid release number because there is no git tag named ${CHECKOUT}."
echo " Please specify one of the following releases:"
- echo "HEAD"
+ echo "HEAD (on branch `git rev-parse --abbrev-ref HEAD`)"
git tag -l | grep "^redist" | cut -f2 -d"/" | sort -u
exit 1
fi
@@ -72,6 +72,7 @@ trap "rm -f \"${MANIFEST}\"; rm -rf \"${TEMP_DIR}\"" 0
# create local copy of Git project at temp location
git archive --format=tar "${CHECKOUT}" --prefix="${PROJECT}-${RELEASE}/" | ( cd "$TEMP_DIR"; tar xf - )
+git --no-pager log --after "1972-01-01" --format="%ai %aN (%h) %n%n%x09*%w(68,0,10) %s%d%n" > "${TEMP_DIR}/${PROJECT}-${RELEASE}/ChangeLog"
echo "Created tarball for $CHECKOUT"
@@ -81,16 +82,20 @@ mkdir -p "doc/applied-patches"
# prepare patches for lite and full tarball
if [ "x$MODE" = "xfull" ]; then
- cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+_.*\.(full|full\+lite)\.patch)" | while read file
+ cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+(_|-).*\.(full|full\+lite)\.patch)" | while read file
do
cp -v "debian/patches/$file" "doc/applied-patches/"
echo "${file##*/}" >> "doc/applied-patches/series"
done
else
+ rm -f "bin/"{nxagent,nxauth,x2goagent}
rm -Rf "nxcompshad"*
rm -Rf "nxcompext"*
rm -Rf "nx-X11"*
- cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+_.*\.full\+lite\.patch)" | while read file
+ rm -Rf "etc"*
+ rm -Rf "doc/nx-X11_vs_XOrg69_patches"*
+ rm -f "README.keystrokes"
+ cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+(_|-).*\.full\+lite\.patch)" | while read file
do
cp -v "debian/patches/$file" "doc/applied-patches/"
echo "${file##*/}" >> "doc/applied-patches/series"
@@ -104,15 +109,19 @@ else
echo "No patches applied at all. Very old release?"
fi
+# remove folders that we do not want to roll into the tarball
+rm -Rf ".pc/"
+rm -Rf "debian/"
+rm -Rf "nx-libs.spec"
+
+# some file renamings
+mv README.md README.NX-Development
+
# very old release did not add any README
for f in $(ls README* 2>/dev/null); do
mv -v "$f" "doc/";
done
-# remove folders that we do not want to roll into the tarball
-rm -Rf ".pc/"
-rm -Rf "debian/"
-
# remove files, that we do not want in the tarballs (build cruft)
rm -Rf nx*/configure nx*/autom4te.cache*