aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control1
-rwxr-xr-xdebian/libnx-xinerama1.postinst.in12
-rw-r--r--debian/libxcomp-dev.install.in1
-rw-r--r--debian/libxcompext-dev.install.in1
-rw-r--r--debian/libxcompshad-dev.install.in1
-rwxr-xr-xdebian/roll-tarballs.sh18
7 files changed, 30 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 2d977e181..0a48e8635 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,7 +12,12 @@ nx-libs (2:3.5.99.0-0~build1) UNRELEASED; urgency=medium
nx-libs (2:3.5.0.33-0x2go1) UNRELEASED; urgency=low
- * Continue development
+ [ Mihai Moldovan ]
+ * debian/control:
+ - Add xkb-data to nxagent's Recommends.
+ * nx-libs.spec:
+ - Add xkeyboard-config to nxagent's Requires. Should be a weak dependency,
+ but RPM doesn't support that too well yet.
-- X2Go Release Manager <git-admin@x2go.org> Sat, 04 Jul 2015 06:29:19 +0200
diff --git a/debian/control b/debian/control
index 08e260a8b..8cbb4bc54 100644
--- a/debian/control
+++ b/debian/control
@@ -957,6 +957,7 @@ Depends:
${misc:Depends},
Recommends:
xfonts-base,
+ xkb-data,
Description: NX agent
NX is a software suite which implements very efficient
compression of the X11 protocol. This increases performance when
diff --git a/debian/libnx-xinerama1.postinst.in b/debian/libnx-xinerama1.postinst.in
index 6d9ba36ef..38cc415f4 100755
--- a/debian/libnx-xinerama1.postinst.in
+++ b/debian/libnx-xinerama1.postinst.in
@@ -28,14 +28,14 @@ case "$1" in
# Already existent files are not removed.
# Users will need to explicitly remove them and (re-) configure this package.
- if ! test -e $libdir/libX11.so.6; then
- ln -s $libdir/libX11.so.6 /usr/lib/nx/X11/Xinerama/libNX_X11.so.6
+ if test -e $libdir/libX11.so.6; then
+ ln -sf $libdir/libX11.so.6 /usr/lib/nx/X11/Xinerama/libNX_X11.so.6
fi
- if ! test -e $libdir/libXext.so.6; then
- ln -s $libdir/libXext.so.6 /usr/lib/nx/X11/Xinerama/libNX_Xext.so.6
+ if test -e $libdir/libXext.so.6; then
+ ln -sf $libdir/libXext.so.6 /usr/lib/nx/X11/Xinerama/libNX_Xext.so.6
fi
- if ! test -e $libdir/libNX_Xinerama.so.1; then
- ln -s $libdir/libNX_Xinerama.so.1 /usr/lib/nx/X11/Xinerama/libXinerama.so.1
+ if test -e $libdir/libNX_Xinerama.so.1; then
+ ln -sf $libdir/libNX_Xinerama.so.1 /usr/lib/nx/X11/Xinerama/libXinerama.so.1
fi
;;
diff --git a/debian/libxcomp-dev.install.in b/debian/libxcomp-dev.install.in
index 7b7bbe591..f0faa49e3 100644
--- a/debian/libxcomp-dev.install.in
+++ b/debian/libxcomp-dev.install.in
@@ -7,3 +7,4 @@ usr/include/*/nx/NXproto.h
usr/include/*/nx/NXrender.h
usr/include/*/nx/NXvars.h
usr/include/*/nx/MD5.h
+usr/lib/*/pkgconfig/nxcomp.pc \ No newline at end of file
diff --git a/debian/libxcompext-dev.install.in b/debian/libxcompext-dev.install.in
index 8be19251e..a31961b99 100644
--- a/debian/libxcompext-dev.install.in
+++ b/debian/libxcompext-dev.install.in
@@ -1,3 +1,4 @@
usr/lib/*/libXcompext.so
usr/include/*/nx/NXlib.h
usr/include/*/nx/NXlibint.h
+usr/lib/*/pkgconfig/nxcompext.pc \ No newline at end of file
diff --git a/debian/libxcompshad-dev.install.in b/debian/libxcompshad-dev.install.in
index fe11227df..31cc685d2 100644
--- a/debian/libxcompshad-dev.install.in
+++ b/debian/libxcompshad-dev.install.in
@@ -10,3 +10,4 @@ usr/include/*/nx/Shadow.h
usr/include/*/nx/Updater.h
usr/include/*/nx/Win.h
usr/include/*/nx/X11.h
+usr/lib/*/pkgconfig/nxcompshad.pc
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index ecaeac2e0..52c2090f0 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -52,7 +52,7 @@ else
fi
if [ x"$RELEASE" == "xHEAD" ]; then
- CHECKOUT=refs/heads/$(git rev-parse --abbrev-ref HEAD)
+ CHECKOUT="refs/heads/$(git rev-parse --abbrev-ref HEAD)"
fi
if ! git rev-parse --verify -q "$CHECKOUT" >/dev/null; then
@@ -78,6 +78,18 @@ echo "Created tarball for $CHECKOUT"
cd "${TEMP_DIR}/${PROJECT}-${RELEASE}/"
+# Replace symlinks by copies of the linked target files
+# Note: We don't have symlinked directories!!!
+find . -type "l" | while read link; do
+ TARGET="$(readlink "${link}")"
+ pushd "$(dirname "${link}")" >/dev/null
+ if [ -f "${TARGET}" ]; then
+ rm -f "$(basename "${link}")"
+ cp "${TARGET}" "$(basename "${link}")"
+ fi
+ popd >/dev/null
+done
+
mkdir -p "doc/applied-patches"
# prepare patches for lite and full tarball
@@ -95,6 +107,7 @@ else
rm -Rf "etc"*
rm -Rf "doc/nx-X11_vs_XOrg69_patches"*
rm -f "README.keystrokes"
+ rm -f "VERSION.x2goagent"
cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+(_|-).*\.full\+lite\.patch)" | while read file
do
cp -v "debian/patches/$file" "doc/applied-patches/"
@@ -114,9 +127,6 @@ rm -Rf ".pc/"
rm -Rf "debian/"
rm -Rf "nx-libs.spec"
-# some file renamings
-mv README.md README.NX-Development
-
# very old release did not add any README
for f in $(ls README* 2>/dev/null); do
mv -v "$f" "doc/";