aboutsummaryrefslogtreecommitdiff
path: root/nx-X11/extras/fontconfig/fc-glyphname/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nx-X11/extras/fontconfig/fc-glyphname/Makefile.am')
-rw-r--r--nx-X11/extras/fontconfig/fc-glyphname/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/nx-X11/extras/fontconfig/fc-glyphname/Makefile.am b/nx-X11/extras/fontconfig/fc-glyphname/Makefile.am
new file mode 100644
index 000000000..eb2110179
--- /dev/null
+++ b/nx-X11/extras/fontconfig/fc-glyphname/Makefile.am
@@ -0,0 +1,51 @@
+#
+# $Id $
+#
+# Copyright © 2003 Keith Packard
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+CC = @CC_FOR_BUILD@
+EXEEXT = @EXEEXT_FOR_BUILD@
+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+
+INCLUDES=-I${top_srcdir}/src -I${top_srcdir} $(FREETYPE_CFLAGS) $(WARN_CFLAGS)
+
+TMPL=fcglyphname.tmpl.h
+STMPL=${top_srcdir}/fc-glyphname/${TMPL}
+TARG=fcglyphname.h
+
+noinst_PROGRAMS=fc-glyphname
+
+noinst_HEADERS=$(TARG)
+
+noinst_MANS=fc-glyphname.man
+
+GLYPHNAME=zapfdingbats.txt
+SGLYPHNAME=${top_srcdir}/fc-glyphname/zapfdingbats.txt
+
+EXTRA_DIST=$(TMPL) $(GLYPHNAME)
+
+$(TARG): $(STMPL) fc-glyphname$(EXEEXT) $(SGLYPHNAME)
+ rm -f $(TARG)
+ ./fc-glyphname$(EXEEXT) $(SGLYPHNAME) < $(STMPL) > $(TARG)
+
+CLEANFILES=$(TARG)
+