aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'nxcomp/configure.in')
-rw-r--r--nxcomp/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/nxcomp/configure.in b/nxcomp/configure.in
index 07c88df77..43b51573a 100644
--- a/nxcomp/configure.in
+++ b/nxcomp/configure.in
@@ -364,6 +364,16 @@ dnl Find makedepend somewhere.
AC_SUBST(MAKEDEPEND)
MAKEDEPEND="$(which makedepend)"
+# Try to desperately find makedepend.
+# Set MAKEDEPEND to the shipped makedepend binary. This will not
+# exist in nx-libs-lite, though, in which case MAKEDEPEND
+# will stay empty.
+if test -z "${MAKEDEPEND}"; then
+ if test -x "../nx-X11/config/makedepend/makedepend"; then
+ MAKEDEPEND="../nx-X11/config/makedepend/makedepend"
+ fi
+fi
+
dnl Determine what to build based on the platform.
dnl Override the LIBS settings on Cygwin32 so that
dnl we always link with the exact set of libraries.