aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'nxcompshad/configure.in')
-rw-r--r--nxcompshad/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/nxcompshad/configure.in b/nxcompshad/configure.in
index 4e91361ff..8dd1b2e21 100644
--- a/nxcompshad/configure.in
+++ b/nxcompshad/configure.in
@@ -271,4 +271,14 @@ dnl Find makedepend somewhere.
AC_SUBST(MAKEDEPEND)
MAKEDEPEND="$(which makedepend)"
+# Try to desperately find makedepend.
+# Set MAKEDEPEND to the shipped makedepend binary. This will not
+# exist in nx-libs-lite, though, in which case MAKEDEPEND
+# will stay empty.
+if test -z "${MAKEDEPEND}"; then
+ if test -x "../nx-X11/config/makedepend/makedepend"; then
+ MAKEDEPEND="../nx-X11/config/makedepend/makedepend"
+ fi
+fi
+
AC_OUTPUT(Makefile)