Build nxcompshad against own nx-X11 sources instead of the system's X11.
--- a/nxcompshad/Makefile.in
+++ b/nxcompshad/Makefile.in
@@ -48,7 +48,7 @@
 CCDEFINES   =
 
 LDFLAGS     = @LDFLAGS@
-LIBS        = @LIBS@ -L/usr/X11R6/lib -lX11
+LIBS        = @LIBS@ -lX11
 
 #
 # Only if THREADS is defined.
@@ -162,7 +162,7 @@
 		-Wl,--enable-auto-import \
 		-Wl,--whole-archive ${LIBARCHIVE} \
 		-Wl,--no-whole-archive \
-		${LIBS} -L/usr/X11R6/lib
+		${LIBS}
 
 $(PROGRAM):	$(MOBJ) $(COBJ) $(CXXOBJ) $(LIBDLL)
 #		$(CC) $(CCFLAGS) -o $@ $(MOBJ) $(MLIBS)
--- a/nxcompshad/configure.in
+++ b/nxcompshad/configure.in
@@ -19,7 +19,7 @@
 
 if test -d "../nx-X11/exports/include" ; then
     CXXFLAGS="$CXXFLAGS -I../nx-X11/exports/include"
-    LIBS="$LIBS -L../nx-X11/exports/lib"
+    LIBS="-L../nx-X11/exports/lib"
 fi
 
 dnl Check whether --with-ipaq was given.