Description: gcc43 fix
 Use builtin includes to build with gcc43.
 .
 Originally contributed by Marcelo Boveto Shima <marceloshima@gmail.com>.
Forwarded: pending...
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Last-Update: 2011-12-31
--- a/nxcompshad/Logger.h
+++ b/nxcompshad/Logger.h
@@ -18,8 +18,8 @@
 #ifndef Logger_H
 #define Logger_H
 
-#include <errno.h>
-#include <stdarg.h>
+#include <cerrno>
+#include <cstdarg>
 
 //
 // Error handling macros.
--- a/nxcompshad/Misc.h
+++ b/nxcompshad/Misc.h
@@ -20,8 +20,8 @@
 
 #include <iostream>
 
-#include <errno.h>
-#include <string.h>
+#include <cerrno>
+#include <cstring>
 
 using namespace std;