Description: gcc43 fix
 Use builtin includes to build with gcc43.
 .
 Originally contributed by Marcelo Boveto Shima <marceloshima@gmail.com>.
Forwarded: not-yet
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Last-Update: 2011-12-31
--- a/nxcomp/Message.cpp	2012-03-01 03:46:39.220943822 +0100
+++ b/nxcomp/Message.cpp	2012-03-01 03:47:27.605712530 +0100
@@ -15,9 +15,9 @@
 /*                                                                        */
 /**************************************************************************/
 
-#include <stdio.h>
+#include <cstdio>
 #include <unistd.h>
-#include <string.h>
+#include <cstring>
 
 #include <algorithm>
 
--- a/nxcomp/Misc.cpp	2012-03-01 03:46:39.220943822 +0100
+++ b/nxcomp/Misc.cpp	2012-03-01 03:47:27.605712530 +0100
@@ -15,11 +15,11 @@
 /*                                                                        */
 /**************************************************************************/
 
-#include <stdio.h>
-#include <ctype.h>
-#include <stdlib.h>
+#include <cstdio>
+#include <cctype>
+#include <cstdlib>
 #include <unistd.h>
-#include <signal.h>
+#include <csignal>
 
 #include <errno.h>
 #include <string.h>
--- a/nxcomp/Misc.h	2012-03-01 03:46:39.220943822 +0100
+++ b/nxcomp/Misc.h	2012-03-01 03:47:27.605712530 +0100
@@ -21,8 +21,8 @@
 #include <iostream>
 #include <fstream>
 
-#include <errno.h>
-#include <string.h>
+#include <cerrno>
+#include <cstring>
 
 #ifdef __sun
 
--- a/nxcomp/Proxy.cpp	2012-03-01 03:46:39.224943897 +0100
+++ b/nxcomp/Proxy.cpp	2012-03-01 03:47:27.605712530 +0100
@@ -15,9 +15,9 @@
 /*                                                                        */
 /**************************************************************************/
 
-#include <stdio.h>
+#include <cstdio>
 #include <unistd.h>
-#include <stdlib.h>
+#include <cstdlib>
 #include <sys/types.h>
 #include <sys/stat.h>
 
--- a/nxcomp/Split.cpp	2012-03-01 03:46:39.224943897 +0100
+++ b/nxcomp/Split.cpp	2012-03-01 03:47:27.605712530 +0100
@@ -16,7 +16,7 @@
 /**************************************************************************/
 
 #include <unistd.h>
-#include <string.h>
+#include <cstring>
 #include <sys/stat.h>
 #include <sys/types.h>
 #include <utime.h>