Description: sa_restorer vs. memset
 Use memset instead of setting .sa_restorer to NULL.
Forwarded: not-yet
Author: Stéphane Graber <stgraber@ubuntu.com>
Last-Update: 2011-12-31
--- a/nxcomp/Loop.cpp
+++ b/nxcomp/Loop.cpp
@@ -5895,7 +5895,7 @@
 
   #if defined(__linux__)
 
-  newAction.sa_restorer = NULL;
+  memset(&newAction, NULL, sizeof(newAction));
 
   #endif
 
@@ -6513,7 +6513,7 @@
 
   #if defined(__linux__)
 
-  action.sa_restorer = NULL;
+  memset(&action, NULL, sizeof(action));
 
   #endif