aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorGZNGET FOSS Team <opensource@gznianguan.com>2016-09-06 15:46:45 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-09-06 15:46:45 +0200
commit6a14d487a699eaa6048b97fd9c75b14cb61d3e3e (patch)
tree0152395b0c09a9a63be4c1d1e00658663a59b43d /Makefile.PL
downloadperl-Arctica-Core-JABus-Socket-6a14d487a699eaa6048b97fd9c75b14cb61d3e3e.tar.gz
perl-Arctica-Core-JABus-Socket-6a14d487a699eaa6048b97fd9c75b14cb61d3e3e.tar.bz2
perl-Arctica-Core-JABus-Socket-6a14d487a699eaa6048b97fd9c75b14cb61d3e3e.zip
initial Arctica JABus implementation
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..1dcdb96
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,14 @@
+use strict;
+use ExtUtils::MakeMaker;
+
+WriteMakefile (
+ AUTHOR => 'Arctica Project Developers',
+ ABSTRACT => "Arctica Framework Core Modules",
+ NAME => 'Arctica::Core::JABus::Socket',
+ (eval { ExtUtils::MakeMaker->VERSION(6.21) } ? (LICENSE => 'perl') : ()),
+ PREREQ_PM => {
+ 'Test::More' => '0.47',
+ },
+ VERSION_FROM => 'lib/Arctica/Core/JABus/Socket/Version.pm',
+ clean => { FILES => '' },
+);