aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-01 08:00:04 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-01 08:00:04 +0100
commit45da05715cd75cb17e13516d534c4a48ec023582 (patch)
treead3dd0c1d6bc31e037fc97ef3fc9f925841c4c34 /CMakeLists.txt
parent7f5119f81fdfa2cc97df91785dcce4798b0700cf (diff)
parentf441fabc655a021e161e59f26c302b9a94b5c3fc (diff)
downloadqmenumodel-45da05715cd75cb17e13516d534c4a48ec023582.tar.gz
qmenumodel-45da05715cd75cb17e13516d534c4a48ec023582.tar.bz2
qmenumodel-45da05715cd75cb17e13516d534c4a48ec023582.zip
Merge branch 'tari01-pr/cleanup-compile-flags'
Attributes GH PR #19: https://github.com/AyatanaIndicators/qmenumodel/pull/19
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd3f3e8..7e11db6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,8 +25,13 @@ if(ENABLE_TESTS)
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
# Standard install paths