aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-15 12:40:44 +0000
committerTarmac <>2012-10-15 12:40:44 +0000
commit5999e7a42962140b6479995d77a178186b6b2fcc (patch)
tree3927d59c3a5edf7362bb4de937ae11fe7291b029 /examples/CMakeLists.txt
parent46b559bd4b2229332c1858939be765939fc6fb05 (diff)
parent4366f70b6d6f5f1788353dd74df15e616365d25b (diff)
downloadqmenumodel-5999e7a42962140b6479995d77a178186b6b2fcc.tar.gz
qmenumodel-5999e7a42962140b6479995d77a178186b6b2fcc.tar.bz2
qmenumodel-5999e7a42962140b6479995d77a178186b6b2fcc.zip
Expose a C++ library, and separate into 3 binary packages:
- libqmenumodel0: C++ library - libqmenumodel-dev: development headers for the C++ library - qmenumodel-qml: QML module. Approved by Renato Araujo Oliveira Filho, jenkins.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..028c6ef
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Standalone CMakeLists.txt to generate the info-menumodel executable.
+# This is not built as part of libqmenumodel, it has to be built separately
+# and it assumes libqmenumodel-dev is installed on the system.
+
+cmake_minimum_required(VERSION 2.8.9)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt5Core REQUIRED)
+
+include(FindPkgConfig)
+pkg_check_modules(QMENUMODEL REQUIRED qmenumodel)
+
+add_executable(info-menumodel info-menumodel.cpp)
+
+qt5_use_modules(info-menumodel Core)
+include_directories(${QMENUMODEL_INCLUDE_DIRS})
+target_link_libraries(info-menumodel ${QMENUMODEL_LDFLAGS})
+