aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-04 17:12:09 +0200
committerOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-04 17:12:09 +0200
commit36cebbb3e17b0b9df03a3a288e56b5d1e1fedee1 (patch)
tree1dcefe0b0813acf2ef4a8aadb2e92388118a3394 /src/common/CMakeLists.txt
parent62d2c4b30435bff7dc25441dd1ce55d519d80b05 (diff)
downloadqmenumodel-36cebbb3e17b0b9df03a3a288e56b5d1e1fedee1.tar.gz
qmenumodel-36cebbb3e17b0b9df03a3a288e56b5d1e1fedee1.tar.bz2
qmenumodel-36cebbb3e17b0b9df03a3a288e56b5d1e1fedee1.zip
Rename the source directories.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt47
1 files changed, 0 insertions, 47 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
deleted file mode 100644
index 2b831b7..0000000
--- a/src/common/CMakeLists.txt
+++ /dev/null
@@ -1,47 +0,0 @@
-project(qmenumodelcommon)
-
-set(QMENUMODELCOMMON_SRC
- converter.cpp
- qmenumodel.cpp
- qdbusobject.cpp
- qdbusmenumodel.cpp
- qdbusactiongroup.cpp
- qstateaction.cpp
-)
-
-set(QMENUMODELCOMMON_HEADERS
- converter.h
- dbus-enums.h
- qmenumodel.h
- qdbusobject.h
- qdbusmenumodel.h
- qdbusactiongroup.h
- qstateaction.h
-)
-
-qt4_wrap_cpp(QMENUMODELCOMMON_MOC
- ${QMENUMODELCOMMON_HEADERS}
-)
-
-add_library(qmenumodelcommon STATIC
- ${QMENUMODELCOMMON_SRC}
- ${QMENUMODELCOMMON_MOC}
-)
-
-set_target_properties(qmenumodelcommon PROPERTIES COMPILE_FLAGS -fPIC)
-
-include_directories(
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${QT_INCLUDE_DIR}
- ${QT_QTCORE_INCLUDE_DIR}
- ${QT_QTGUI_INCLUDE_DIR}
- ${GLIB_INCLUDE_DIRS}
- ${GIO_INCLUDE_DIRS}
-)
-
-target_link_libraries(qmenumodelcommon
- ${QT_QTCORE_LIBRARY}
- ${QT_QTGUI_LIBRARY}
- ${GLIB_LDFLAGS}
- ${GIO_LDFLAGS}
-)