aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-05 13:26:10 +0000
committerTarmac <>2012-10-05 13:26:10 +0000
commitc3fbab270f60fc374bae50e787e0b2046f127a07 (patch)
tree61d0eae8f1c1e3d23fb6559cb19e920b167b187c /tests/client/CMakeLists.txt
parent7961150ad1eaa1b3bc62d5215e274a7b58b0ef72 (diff)
parent696fba50395807c344325af11e71ec74cf370c3d (diff)
downloadqmenumodel-c3fbab270f60fc374bae50e787e0b2046f127a07.tar.gz
qmenumodel-c3fbab270f60fc374bae50e787e0b2046f127a07.tar.bz2
qmenumodel-c3fbab270f60fc374bae50e787e0b2046f127a07.zip
Tweaks to the structure of the code, and added example code.. Approved by Renato Araujo Oliveira Filho, jenkins.
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index c427f54..2c48a07 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -4,7 +4,7 @@ macro(declare_test testname)
add_executable(${testname} ${testname}.cpp ${TEST_MOC_FILE})
target_link_libraries(${testname}
- qmenumodelcommon
+ qmenumodel
dbusmenuscript
${QT_QTTEST_LIBRARY}
${QT_QTCORE_LIBRARY}
@@ -30,7 +30,7 @@ macro(declare_simple_test testname)
add_executable(${testname} ${testname}.cpp ${TEST_MOC_FILE})
target_link_libraries(${testname}
- qmenumodelcommon
+ qmenumodel
${QT_QTTEST_LIBRARY}
${QT_QTCORE_LIBRARY}
${QT_QTGUI_LIBRARY}
@@ -45,7 +45,7 @@ macro(declare_simple_test testname)
TIMEOUT ${CTEST_TESTING_TIMEOUT})
endmacro(declare_simple_test testname)
-include_directories(${qmenumodelcommon_SOURCE_DIR}
+include_directories(${src_SOURCE_DIR}
${dbusmenuscript_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${QT_INCLUDE_DIR}