aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-23 12:03:54 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-23 12:03:54 -0300
commitf68764ac84a0aba3c729d4998ca64919bf3375f4 (patch)
treeb0fd94cdaa2df96a70cbdc636fee4cb1878d5dd9 /tests/client/CMakeLists.txt
parent6078bd7ddc6819d2650435313bb824442bbe033d (diff)
parentde8eea63b919b81132895dfe04ed676778c53f6f (diff)
downloadqmenumodel-f68764ac84a0aba3c729d4998ca64919bf3375f4.tar.gz
qmenumodel-f68764ac84a0aba3c729d4998ca64919bf3375f4.tar.bz2
qmenumodel-f68764ac84a0aba3c729d4998ca64919bf3375f4.zip
Merged mainline.
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index d946fad..392437c 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -8,9 +8,15 @@ macro(declare_test testname)
${GIO_LDFLAGS}
)
+ if(TEST_XML_OUTPUT)
+ set(TEST_ARGS -p -xunitxml -p -o -p test_${testname}.xml)
+ else()
+ set(TEST_ARGS "")
+ endif()
+
add_test(${testname}
${DBUS_RUNNER}
- --task ${CMAKE_CURRENT_BINARY_DIR}/${testname} -p -xunitxml -p -o -p test_${testname}.xml --task-name Client
+ --task ${CMAKE_CURRENT_BINARY_DIR}/${testname} ${TEST_ARGS} --task-name Client
--task ${CMAKE_CURRENT_SOURCE_DIR}/script_${testname}.py --task-name Server
--ignore-return)
set_tests_properties(${testname} PROPERTIES