aboutsummaryrefslogtreecommitdiff
path: root/X11/extensions/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-10-05 06:44:44 +0000
committermarha <marha@users.sourceforge.net>2010-10-05 06:44:44 +0000
commit51f3d1e140307561f64c47dae1d44f912accb5cf (patch)
tree9432aedd19f670b1a72a1e8b4503f286fa910102 /X11/extensions/Makefile.am
parentf07afca523ad174acd3c56fc43111a09b7a5243e (diff)
downloadvcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.tar.gz
vcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.tar.bz2
vcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.zip
Update to the following packages:
- glproto-1.4.12 - kbproto-1.0.5 - renderproto-0.11.1 - xclock-1.0.5 - xextproto-7.1.2 - xproto-7.0.18 - xwininfo-1.1.0
Diffstat (limited to 'X11/extensions/Makefile.am')
-rw-r--r--X11/extensions/Makefile.am22
1 files changed, 17 insertions, 5 deletions
diff --git a/X11/extensions/Makefile.am b/X11/extensions/Makefile.am
index 8cdd0ac97..bbe5dd42e 100644
--- a/X11/extensions/Makefile.am
+++ b/X11/extensions/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS=specs
+
xextdir = $(includedir)/X11/extensions
xext_HEADERS = \
dpmsconst.h \
@@ -31,17 +33,27 @@ xext_HEADERS = \
xtestconst.h \
xtestproto.h
+#
+# These headers allow old servers to be built with
+# new headers
+#
+compatdir = $(xextdir)
+compat_HEADERS = \
+ shapestr.h \
+ shmstr.h \
+ syncstr.h
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xextproto.pc
-EXTRA_DIST = xextproto.pc.in geproto.txt
+MAINTAINERCLEANFILES = ChangeLog INSTALL
-EXTRA_DIST += ChangeLog
-MAINTAINERCLEANFILES = ChangeLog
+.PHONY: ChangeLog INSTALL
-.PHONY: ChangeLog
+INSTALL:
+ $(INSTALL_CMD)
ChangeLog:
$(CHANGELOG_CMD)
-dist-hook: ChangeLog
+dist-hook: ChangeLog INSTALL