aboutsummaryrefslogtreecommitdiff
path: root/X11/xtrans/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-10-18 12:07:02 +0000
committermarha <marha@users.sourceforge.net>2009-10-18 12:07:02 +0000
commitb567a3027bceabc0f1f42dd162268f06f15e8149 (patch)
tree30e9dda79caf9b5fb6e375c352282ca5845c699c /X11/xtrans/Makefile.am
parent0c5e1ab504b4e8c56974a234bd440e9fa2f1f941 (diff)
downloadvcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.tar.gz
vcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.tar.bz2
vcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.zip
Updated following packages:
libX11-1.3.1 xtrans-1.2.5
Diffstat (limited to 'X11/xtrans/Makefile.am')
-rw-r--r--X11/xtrans/Makefile.am46
1 files changed, 44 insertions, 2 deletions
diff --git a/X11/xtrans/Makefile.am b/X11/xtrans/Makefile.am
index f30b57ac9..fa6ef1515 100644
--- a/X11/xtrans/Makefile.am
+++ b/X11/xtrans/Makefile.am
@@ -12,10 +12,10 @@ Xtransinclude_HEADERS = \
aclocaldir = $(datadir)/aclocal
aclocal_DATA = xtrans.m4
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = xtrans.pc
-EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog
+EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog Xtrans.mm
MAINTAINERCLEANFILES = ChangeLog
@@ -25,3 +25,45 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog
+
+# Rules to convert documentation from troff to other formats
+doc_sources = Xtrans.mm
+
+if HAVE_PS2PDF
+printable_format = .pdf
+else
+printable_format = .ps
+endif
+
+if BUILD_DOCS
+doc_DATA = $(doc_sources:.mm=.txt) \
+ $(doc_sources:.mm=$(printable_format)) \
+ $(doc_sources:.mm=.html)
+
+CLEANFILES = $(doc_DATA)
+MOSTLYCLEANFILES = index.*
+
+# Pass version string as a troff string for substitution
+GROFF_DEFS = -dxV="$(PACKAGE_STRING)"
+
+# -t to run through tbl
+GROFF_FLAGS = -t -mm $(GROFF_DEFS)
+
+SUFFIXES = .mm .ps .txt .html .pdf
+
+.mm.ps:
+ -$(AM_V_GEN) $(GROFF) -Tps $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+ @if grep '^[^1-9.]' index.$@.raw | grep -v warning; then exit 1; \
+ else test $$? -le 1; fi
+
+.mm.txt:
+ $(AM_V_GEN) env GROFF_NO_SGR=TRUE $(GROFF) -Tutf8 $(GROFF_FLAGS) \
+ $< 2> index.$@.raw > $@
+
+.mm.html:
+ $(AM_V_GEN) $(GROFF) -Thtml $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+
+.ps.pdf:
+ $(AM_V_GEN) $(PS2PDF) $< $@
+
+endif BUILD_DOCS