aboutsummaryrefslogtreecommitdiff
path: root/X11/xtrans/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-10-18 13:41:37 +0000
committermarha <marha@users.sourceforge.net>2009-10-18 13:41:37 +0000
commit814b98c7e9cde9c8e97b476e6d409bc2607d846c (patch)
tree1a191c9f7bafa0d184aefca0a5b995ad4c4e1fd9 /X11/xtrans/Makefile.am
parent27bc6d5e30150409259aa9030e668e801eb0b5a6 (diff)
parentb567a3027bceabc0f1f42dd162268f06f15e8149 (diff)
downloadvcxsrv-814b98c7e9cde9c8e97b476e6d409bc2607d846c.tar.gz
vcxsrv-814b98c7e9cde9c8e97b476e6d409bc2607d846c.tar.bz2
vcxsrv-814b98c7e9cde9c8e97b476e6d409bc2607d846c.zip
svn merge ^/branches/released
Diffstat (limited to 'X11/xtrans/Makefile.am')
-rw-r--r--X11/xtrans/Makefile.am46
1 files changed, 44 insertions, 2 deletions
diff --git a/X11/xtrans/Makefile.am b/X11/xtrans/Makefile.am
index f30b57ac9..fa6ef1515 100644
--- a/X11/xtrans/Makefile.am
+++ b/X11/xtrans/Makefile.am
@@ -12,10 +12,10 @@ Xtransinclude_HEADERS = \
aclocaldir = $(datadir)/aclocal
aclocal_DATA = xtrans.m4
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = xtrans.pc
-EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog
+EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog Xtrans.mm
MAINTAINERCLEANFILES = ChangeLog
@@ -25,3 +25,45 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog
+
+# Rules to convert documentation from troff to other formats
+doc_sources = Xtrans.mm
+
+if HAVE_PS2PDF
+printable_format = .pdf
+else
+printable_format = .ps
+endif
+
+if BUILD_DOCS
+doc_DATA = $(doc_sources:.mm=.txt) \
+ $(doc_sources:.mm=$(printable_format)) \
+ $(doc_sources:.mm=.html)
+
+CLEANFILES = $(doc_DATA)
+MOSTLYCLEANFILES = index.*
+
+# Pass version string as a troff string for substitution
+GROFF_DEFS = -dxV="$(PACKAGE_STRING)"
+
+# -t to run through tbl
+GROFF_FLAGS = -t -mm $(GROFF_DEFS)
+
+SUFFIXES = .mm .ps .txt .html .pdf
+
+.mm.ps:
+ -$(AM_V_GEN) $(GROFF) -Tps $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+ @if grep '^[^1-9.]' index.$@.raw | grep -v warning; then exit 1; \
+ else test $$? -le 1; fi
+
+.mm.txt:
+ $(AM_V_GEN) env GROFF_NO_SGR=TRUE $(GROFF) -Tutf8 $(GROFF_FLAGS) \
+ $< 2> index.$@.raw > $@
+
+.mm.html:
+ $(AM_V_GEN) $(GROFF) -Thtml $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+
+.ps.pdf:
+ $(AM_V_GEN) $(PS2PDF) $< $@
+
+endif BUILD_DOCS