aboutsummaryrefslogtreecommitdiff
path: root/X11/xtrans/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-12-26 19:58:42 +0000
committermarha <marha@users.sourceforge.net>2010-12-26 19:58:42 +0000
commitbfc120af66586bc6c79cd65a6bc7733b7ccdb428 (patch)
treea82a4e49f73fe3cf8871a1c49c7eaf4fa4836175 /X11/xtrans/Makefile.am
parentc2c3ce5abd338cb6345780cb86c30ca9f34a6562 (diff)
downloadvcxsrv-bfc120af66586bc6c79cd65a6bc7733b7ccdb428.tar.gz
vcxsrv-bfc120af66586bc6c79cd65a6bc7733b7ccdb428.tar.bz2
vcxsrv-bfc120af66586bc6c79cd65a6bc7733b7ccdb428.zip
Update to xtrans 1.2.6
Diffstat (limited to 'X11/xtrans/Makefile.am')
-rw-r--r--X11/xtrans/Makefile.am54
1 files changed, 8 insertions, 46 deletions
diff --git a/X11/xtrans/Makefile.am b/X11/xtrans/Makefile.am
index fa6ef1515..9ff172370 100644
--- a/X11/xtrans/Makefile.am
+++ b/X11/xtrans/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS=doc
+
Xtransincludedir = $(includedir)/X11/Xtrans
Xtransinclude_HEADERS = \
Xtrans.h \
@@ -15,55 +17,15 @@ aclocal_DATA = xtrans.m4
pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = xtrans.pc
-EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog Xtrans.mm
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+EXTRA_DIST = ${aclocal_DATA}
-MAINTAINERCLEANFILES = ChangeLog
+.PHONY: ChangeLog INSTALL
-.PHONY: ChangeLog
+INSTALL:
+ $(INSTALL_CMD)
ChangeLog:
$(CHANGELOG_CMD)
-dist-hook: ChangeLog
-
-# Rules to convert documentation from troff to other formats
-doc_sources = Xtrans.mm
-
-if HAVE_PS2PDF
-printable_format = .pdf
-else
-printable_format = .ps
-endif
-
-if BUILD_DOCS
-doc_DATA = $(doc_sources:.mm=.txt) \
- $(doc_sources:.mm=$(printable_format)) \
- $(doc_sources:.mm=.html)
-
-CLEANFILES = $(doc_DATA)
-MOSTLYCLEANFILES = index.*
-
-# Pass version string as a troff string for substitution
-GROFF_DEFS = -dxV="$(PACKAGE_STRING)"
-
-# -t to run through tbl
-GROFF_FLAGS = -t -mm $(GROFF_DEFS)
-
-SUFFIXES = .mm .ps .txt .html .pdf
-
-.mm.ps:
- -$(AM_V_GEN) $(GROFF) -Tps $(GROFF_FLAGS) $< 2> index.$@.raw > $@
- @if grep '^[^1-9.]' index.$@.raw | grep -v warning; then exit 1; \
- else test $$? -le 1; fi
-
-.mm.txt:
- $(AM_V_GEN) env GROFF_NO_SGR=TRUE $(GROFF) -Tutf8 $(GROFF_FLAGS) \
- $< 2> index.$@.raw > $@
-
-.mm.html:
- $(AM_V_GEN) $(GROFF) -Thtml $(GROFF_FLAGS) $< 2> index.$@.raw > $@
-
-.ps.pdf:
- $(AM_V_GEN) $(PS2PDF) $< $@
-
-endif BUILD_DOCS
+dist-hook: ChangeLog INSTALL