aboutsummaryrefslogtreecommitdiff
path: root/X11/xtrans/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-10-18 12:07:02 +0000
committermarha <marha@users.sourceforge.net>2009-10-18 12:07:02 +0000
commitb567a3027bceabc0f1f42dd162268f06f15e8149 (patch)
tree30e9dda79caf9b5fb6e375c352282ca5845c699c /X11/xtrans/configure.ac
parent0c5e1ab504b4e8c56974a234bd440e9fa2f1f941 (diff)
downloadvcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.tar.gz
vcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.tar.bz2
vcxsrv-b567a3027bceabc0f1f42dd162268f06f15e8149.zip
Updated following packages:
libX11-1.3.1 xtrans-1.2.5
Diffstat (limited to 'X11/xtrans/configure.ac')
-rw-r--r--X11/xtrans/configure.ac27
1 files changed, 21 insertions, 6 deletions
diff --git a/X11/xtrans/configure.ac b/X11/xtrans/configure.ac
index 3fcf515c9..45757bfea 100644
--- a/X11/xtrans/configure.ac
+++ b/X11/xtrans/configure.ac
@@ -21,13 +21,15 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
-AC_INIT(xtrans, 1.2.4, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xtrans)
+AC_INIT(xtrans, [1.2.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xtrans)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros version 1.2.0 or newer for XORG_CHANGELOG macro
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
# Because xtrans is included into other modules rather than being linked
# with, these defines have to be added to the cflags line
@@ -47,8 +49,21 @@ sticky_bit_define="-DHAS_STICKY_DIR_BIT"
AC_SUBST(sticky_bit_define)
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
+# Documentation is currently provided in troff format, built on request
+AC_PATH_PROGS([GROFF], [groff], [none], [$PATH:/usr/gnu/bin])
+AC_PATH_PROGS([PS2PDF], [ps2pdf], [none], [$PATH:/usr/gnu/bin])
+
+AC_MSG_CHECKING([whether to build documentation])
+AC_ARG_ENABLE(docs, AC_HELP_STRING([--enable-docs],
+ [Enable building of documentation]),
+ [build_docs="${enableval}"], [build_docs="no"])
+AC_MSG_RESULT([${build_docs}])
+if test "x${build_docs}" = xyes && test "x${GROFF}" = xnone ; then
+ AC_MSG_ERROR([can't build documentation without groff])
+fi
+
+AM_CONDITIONAL(BUILD_DOCS, [test x$build_docs = xyes])
+AM_CONDITIONAL(HAVE_PS2PDF, [test x$PS2PDF != xnone])
AC_OUTPUT([Makefile
xtrans.pc])