aboutsummaryrefslogtreecommitdiff
path: root/apps/xcalc/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2015-02-22 21:39:56 +0100
committermarha <marha@users.sourceforge.net>2015-02-22 21:39:56 +0100
commit462f18c7b25fe3e467f837647d07ab0a78aa8d2b (patch)
treefc8013c0a1bac05a1945846c1697e973f4c35013 /apps/xcalc/configure.ac
parent36f711ee12b6dd5184198abed3aa551efb585587 (diff)
downloadvcxsrv-462f18c7b25fe3e467f837647d07ab0a78aa8d2b.tar.gz
vcxsrv-462f18c7b25fe3e467f837647d07ab0a78aa8d2b.tar.bz2
vcxsrv-462f18c7b25fe3e467f837647d07ab0a78aa8d2b.zip
Merged origin/release (checked in because wanted to merge new stuff)
Diffstat (limited to 'apps/xcalc/configure.ac')
-rw-r--r--apps/xcalc/configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/apps/xcalc/configure.ac b/apps/xcalc/configure.ac
index 3a0fb2a87..efeb403f1 100644
--- a/apps/xcalc/configure.ac
+++ b/apps/xcalc/configure.ac
@@ -23,14 +23,13 @@ dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xcalc], [1.0.5],
+AC_INIT([xcalc], [1.0.6],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xcalc])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
-AM_MAINTAINER_MODE
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
@@ -38,8 +37,10 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
+AC_CHECK_FUNCS([strlcpy])
+
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XCALC, xaw7 xt x11)
+PKG_CHECK_MODULES(XCALC, [xaw7 xt x11 xproto >= 7.0.17])
PKG_CHECK_MODULES(APPDEFS, xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`