aboutsummaryrefslogtreecommitdiff
path: root/apps/xwininfo/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-11-06 16:19:08 +0000
committermarha <marha@users.sourceforge.net>2009-11-06 16:19:08 +0000
commit0032f9b66d63a4b1c5222edb8603fb60da379fb0 (patch)
tree1b13bd935f607da87239a5a85e78f7940996dd84 /apps/xwininfo/configure.ac
parentfa6c428cc762a412544f98f3514dd05158b1cf9b (diff)
downloadvcxsrv-0032f9b66d63a4b1c5222edb8603fb60da379fb0.tar.gz
vcxsrv-0032f9b66d63a4b1c5222edb8603fb60da379fb0.tar.bz2
vcxsrv-0032f9b66d63a4b1c5222edb8603fb60da379fb0.zip
Added xwininfo-1.0.5
Diffstat (limited to 'apps/xwininfo/configure.ac')
-rw-r--r--apps/xwininfo/configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/apps/xwininfo/configure.ac b/apps/xwininfo/configure.ac
new file mode 100644
index 000000000..b4b8785ff
--- /dev/null
+++ b/apps/xwininfo/configure.ac
@@ -0,0 +1,48 @@
+
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(xwininfo, [1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xwininfo)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+XORG_DEFAULT_OPTIONS
+
+AC_CHECK_FUNCS([strlcat])
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XWININFO, xext x11)
+AC_SUBST(XWININFO_CFLAGS)
+AC_SUBST(XWININFO_LIBS)
+
+AC_OUTPUT([Makefile])