aboutsummaryrefslogtreecommitdiff
path: root/libxcb/xcb-proto/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-07-25 11:41:54 +0000
committermarha <marha@users.sourceforge.net>2009-07-25 11:41:54 +0000
commit1204cba5d6dbdfc8fc31cb7c4a4e467b9c55fc48 (patch)
tree54f50dac14b7b1e158ba7e18fc87d84455970910 /libxcb/xcb-proto/configure.ac
parent12fa8ee5d6535841f016c03c07f1d5cfc54513b0 (diff)
parent1dad159fe09ac3a88b21b98544880e5ecc0e8d54 (diff)
downloadvcxsrv-1204cba5d6dbdfc8fc31cb7c4a4e467b9c55fc48.tar.gz
vcxsrv-1204cba5d6dbdfc8fc31cb7c4a4e467b9c55fc48.tar.bz2
vcxsrv-1204cba5d6dbdfc8fc31cb7c4a4e467b9c55fc48.zip
svn merge file:///D:/svnrepos/vcxsrv/branches/released .
Diffstat (limited to 'libxcb/xcb-proto/configure.ac')
-rw-r--r--libxcb/xcb-proto/configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/libxcb/xcb-proto/configure.ac b/libxcb/xcb-proto/configure.ac
new file mode 100644
index 000000000..f3a489e2b
--- /dev/null
+++ b/libxcb/xcb-proto/configure.ac
@@ -0,0 +1,22 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT([XCB Proto],
+ 1.5,
+ [xcb@lists.freedesktop.org])
+AC_CONFIG_SRCDIR([xcb-proto.pc.in])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+
+AC_PATH_PROG(XMLLINT, xmllint, no)
+AM_CONDITIONAL(HAVE_XMLLINT, test "x$XMLLINT" != "xno")
+if test "$XMLLINT" = "no"; then
+ AC_MSG_WARN([xmllint not found; unable to validate against schema.])
+fi
+
+AM_PATH_PYTHON([2.5])
+
+xcbincludedir='${datadir}/xcb'
+AC_SUBST(xcbincludedir)
+
+AC_OUTPUT([Makefile src/Makefile xcbgen/Makefile xcb-proto.pc])