aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-03-06 08:39:27 +0100
committermarha <marha@users.sourceforge.net>2013-03-06 08:39:27 +0100
commitb5acb643ab1a86b31409900a7c03281fcc48c8e3 (patch)
tree85db12bb6d437f616b2f91d547426d0e2d3173e6 /mesalib/configure.ac
parent6ddd685990187ec5f5996a16951a3d780c820272 (diff)
parent84798668341b15890d625e3bffbbc2d19f434568 (diff)
downloadvcxsrv-b5acb643ab1a86b31409900a7c03281fcc48c8e3.tar.gz
vcxsrv-b5acb643ab1a86b31409900a7c03281fcc48c8e3.tar.bz2
vcxsrv-b5acb643ab1a86b31409900a7c03281fcc48c8e3.zip
Merge remote-tracking branch 'origin/released'
* origin/released: fontconfig libfontenc mesa xserver git update 6 Mar 2013
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 5f95a78d2..ea56a044d 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -832,20 +832,6 @@ if test "x$enable_dri" = xyes; then
fi
fi
-dnl Find out if X is available.
-PKG_CHECK_MODULES([X11], [x11], [no_x=no], [no_x=yes])
-
-dnl Try to tell the user that the --x-* options are only used when
-dnl pkg-config is not available. This must be right after AC_PATH_XTRA.
-m4_divert_once([HELP_BEGIN],
-[These options are only used when the X libraries cannot be found by the
-pkg-config utility.])
-
-dnl We need X for xlib and dri, so bomb now if it's not found
-if test "x$enable_glx" = xyes -a "x$no_x" = xyes; then
- AC_MSG_ERROR([X11 development libraries needed for GLX])
-fi
-
dnl Direct rendering or just indirect rendering
case "$host_os" in
gnu*)
@@ -1095,7 +1081,7 @@ if test "x$enable_dri" = xyes; then
fi
# if we are building any dri driver other than swrast or using the dri state tracker ...
- if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast || test "x$enable_dri" = xyes; then
+ if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast -a "x$enable_dri" = xyes; then
# ... libdrm is required
if test "x$have_libdrm" != xyes; then
AC_MSG_ERROR([DRI drivers requires libdrm >= $LIBDRM_REQUIRED])